Share

AnchorLocationType Enumeration

Enumerates where to anchor various label annotations.

Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.5.3784.0

Syntax

C#

public enum AnchorLocationType

Visual Basic

Public Enumeration AnchorLocationType

Visual C++

public enum class AnchorLocationType

Members

Member nameValueDescription
TopLeft134263044
TopCenter134263045
TopRight134263046
MiddleLeft134263047
MiddleCenter134263048
MiddleRight134263049
BottomLeft134263050
BottomCenter134263051
BottomRight134263052
Start134263041
Middle134263042
End134263043
InsertionPoint134263053
Station134263072
LabelLocation134263073
PI134263074
PVI134263088
CurveStart134263089
CurveEnd134263090
PVIExtension134263091
CurveStartExtension134263092
CurveMiddleExtension134263093
CurveEndExtension134263094
CurveHighPoint134263095
CurveLowPoint134263096
TangentStart134263097
TangentMiddle134263098
TangentEnd134263099
TangentStartExtension134263100
TangentMiddleExtension134263101
TangentEndExtension134263102
StationExtension134263103
BandTop134263104
BandMiddle134263105
BandBottom134263106
StartExtension134263107
MiddleExtension134263108
EndExtension134263109
Offset134263152
GradeBreak134263154
GradeBreakExtension134263155

Remarks

Used in BlockLabelStyles, VectorArrowLabelStyles, LineLabelStyles, and TextLabelStyles. There are nine anchor point values representing points along a rectangle that encompasses the entire text component and are relative to the rotation angle of the text.

See Also

Was this information helpful?