Share

EntityNotFoundException Class

The exception that's thrown when an attempt is made to access a non-existent entity. For example, calling ProfileEntity.EntityBefore() on the first entity.

Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.5.3784.0

Syntax

C#

[SerializableAttribute]
public class EntityNotFoundException : CivilException

Visual Basic

<SerializableAttribute> _
Public Class EntityNotFoundException _
	Inherits CivilException

Visual C++

[SerializableAttribute]
public ref class EntityNotFoundException : public CivilException

Inheritance Hierarchy

System.Object
  System.Exception
    Autodesk.Civil.CivilException
      Autodesk.Civil.EntityNotFoundException

See Also

Was this information helpful?