Share

AnchorPointType Enumeration

Enumerates where to anchor various label annotations.

Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.5.3784.0

Syntax

C#

public enum AnchorPointType

Visual Basic

Public Enumeration AnchorPointType

Visual C++

public enum class AnchorPointType

Members

Member nameValueDescription
Start134263041
Middle134263042
End134263043
TopLeft134263044
TopCenter134263045
TopRight134263046
MiddleLeft134263047
MiddleCenter134263048
MiddleRight134263049
BottomLeft134263050
BottomCenter134263051
BottomRight134263052
InsertionPoint134263053
Center134263054
PointOfIntersection134263055
Station134263072
PI134263074
PVI134263088
CurveStart134263089
CurveEnd134263090
PVIDimension134263091
CurveStartDimension134263092
CurveMidDimension134263093
CurveEndDimension134263094
CurveHighPoint134263095
CurveLowPoint134263096
TangentStart134263097
TangentMiddle134263098
TangentEnd134263099
TangentStartDimension134263100
TangentMiddleDimension134263101
TangentEndDimension134263102
TangentInStart134263075
TangentInMiddle134263076
TangentOutMiddle134263078
TangentOutEnd134263079
StationExtension134263103
PVIStart134263120
PVIEnd134263121
PVIStartDimension134263122
PVIEndDimension134263123
CurveMid134263128
CurveHighPointDimension134263129
CurveLowPointDimension134263130
CurveStartInView134263184
CurveEndInView134263185
CurveStartInViewDimension134263186
CurveEndInViewDimension134263187
TangentStartInView134263188
TangentEndInView134263189
TangentStartInViewDimension134263190
TangentEndInViewDimension134263191
PVIStartInView134263192
PVIEndInView134263193
PVIStartInViewDimension134263194
PVIEndInViewDimension134263195
StartExtension134263107
MiddleExtension134263108
EndExtension134263109
Offset134263152
OffsetExtension134263153
GradeBreak134263154
GradeBreakExtension134263155
Centerline134263156
TopOuterDiameter134263157
TopInnerDiameter134263158
BottomOuterDiameter134263159
BottomInnerDiameter134263160
PipeDimension134263161
StructureDimension134263162
SectionViewTop134263168
SectionViewBottom134263169
SectionViewTopAtStart134263170
SectionViewBottomAtStart134263171
SectionViewTopAtMiddle134263172
SectionViewBottomAtMiddle134263173
SectionViewTopAtEnd134263174
SectionViewBottomAtEnd134263175
SegmentMiddleSuperelevationBand134264080
Insertion134264184
Dimension134264185
LabelLocation134263296
BandTop134263104
BandMiddle134263105
BandBottom134263106
PreviousStationBandTop134264160
PreviousStationBandMiddle134264161
PreviousStationBandBottom134264162
LengthMidBandTop134264163
LengthMidBandMiddle134264164
LengthMidBandBottom134264165
NextStationBandTop134264166
NextStationBandMiddle134264167
NextStationBandBottom134264168
SegmentStartAndBandTop134264082
SegmentStartAndBandMiddle134264083
SegmentStartAndBandBot134264084
SegmentMiddleAndBandTop134264085
SegmentMiddleAndBandMiddle134264086
SegmentMiddleAndBandBot134264087
SegmentEndAndBandTop134264088
SegmentEndAndBandMiddle134264089
SegmentEndAndBandBot134264090
SchematicLineStart134264091
SchematicLineMid134264092
SchematicLineEnd134264093
PreviousOffsetBandTop134264144
PreviousOffsetBandMiddle134264145
PreviousOffsetBandBottom134264146
NextOffsetBandTop134264150
NextOffsetBandMiddle134264151
NextOffsetBandBottom134264152

Remarks

Use for all the label style components.

See Also

Was this information helpful?