Property template for enumerations.
Inheritance Hierarchy
SystemObjectSystemMarshalByRefObject
DisposableWrapper
TreeOidWrapper
Autodesk.CivilProperty<int,int,Autodesk::Civil::CastOp<int,int> >
Autodesk.CivilPropertyEnumT
Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.6.1067.0
Syntax
C#
public class PropertyEnum<T> : Property<int,int,Autodesk::Civil::CastOp<int,int> > where T : struct, new()
VB
Public Class PropertyEnum(Of T As {Structure, New}) Inherits Property<int,int,Autodesk::Civil::CastOp<int,int> >
C++
generic<typename T> where T : value class, gcnew() public ref class PropertyEnum : public Property<int,int,Autodesk::Civil::CastOp<int,int> >
Type Parameters
- T
The PropertyEnumT type exposes the following members.
Properties
Name | Description | |
---|---|---|
![]() | Value |
Methods
Name | Description | |
---|---|---|