Share

PropertyString Class

String property template.

Inheritance Hierarchy

SystemObject
  SystemMarshalByRefObject
    DisposableWrapper
      TreeOidWrapper
        Autodesk.CivilProperty<System::String ^,AecRmCString,Autodesk::Civil::CastOp<System::String ^,AecRmCString> >
          Autodesk.CivilPropertyString
            More

Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.6.1067.0

Syntax

C#

public class PropertyString : Property<System::String ^,AecRmCString,Autodesk::Civil::CastOp<System::String ^,AecRmCString> >

VB

Public Class PropertyString
	Inherits Property<System::String ^,AecRmCString,Autodesk::Civil::CastOp<System::String ^,AecRmCString> >

C++

public ref class PropertyString : public Property<System::String ^,AecRmCString,Autodesk::Civil::CastOp<System::String ^,AecRmCString> >

The PropertyString type exposes the following members.

Properties

Methods

See Also

Reference

Inheritance Hierarchy

SystemObject
  SystemMarshalByRefObject
    DisposableWrapper
      TreeOidWrapper
        Autodesk.CivilProperty<System::String ^,AecRmCString,Autodesk::Civil::CastOp<System::String ^,AecRmCString> >
          Autodesk.CivilPropertyString
            Autodesk.CivilPropertyArrowhead
            Autodesk.CivilPropertyBlock
            Autodesk.CivilPropertyExpression
            Autodesk.CivilPropertyLayer
            Autodesk.CivilPropertyLinetype
            Autodesk.CivilPropertyMaterial
            Autodesk.CivilPropertyMText
            Autodesk.CivilPropertyNameTemplate
            Autodesk.CivilPropertyObjectName
            Autodesk.CivilPropertyTextStyle

Was this information helpful?