Share

SurveyException Class

This class hanle the exception for any operation on the survey.

Inheritance Hierarchy

SystemObject
  SystemException
    Autodesk.CivilCivilException
      Autodesk.CivilSurveyException


Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.6.1067.0

Syntax

C#

[SerializableAttribute]
public class SurveyException : CivilException

VB

<SerializableAttribute>
Public Class SurveyException
	Inherits CivilException

C++

[SerializableAttribute]
public ref class SurveyException : public CivilException

The SurveyException type exposes the following members.

Constructors

 NameDescription
Public methodSurveyExceptionInitializes a new instance of the SurveyException class
Public methodSurveyException(String)Initializes a new instance of the SurveyException class
Public methodSurveyException(SurveyStatus)Initializes a new instance of the SurveyException class
Public methodSurveyException(String, Exception)Initializes a new instance of the SurveyException class
Public methodSurveyException(SurveyStatus, String)Initializes a new instance of the SurveyException class

See Also

Reference

Was this information helpful?