Enumerates where to anchor various label annotations.
Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.6.1067.0
Syntax
C#
public enum AnchorLocationType
VB
Public Enumeration AnchorLocationType
C++
public enum class AnchorLocationType
Members
Member name | Value | Description |
---|---|---|
Start | 134,263,041 | |
Middle | 134,263,042 | |
End | 134,263,043 | |
TopLeft | 134,263,044 | |
TopCenter | 134,263,045 | |
TopRight | 134,263,046 | |
MiddleLeft | 134,263,047 | |
MiddleCenter | 134,263,048 | |
MiddleRight | 134,263,049 | |
BottomLeft | 134,263,050 | |
BottomCenter | 134,263,051 | |
BottomRight | 134,263,052 | |
InsertionPoint | 134,263,053 | |
Station | 134,263,072 | |
LabelLocation | 134,263,073 | |
PI | 134,263,074 | |
PVI | 134,263,088 | |
CurveStart | 134,263,089 | |
CurveEnd | 134,263,090 | |
PVIExtension | 134,263,091 | |
CurveStartExtension | 134,263,092 | |
CurveMiddleExtension | 134,263,093 | |
CurveEndExtension | 134,263,094 | |
CurveHighPoint | 134,263,095 | |
CurveLowPoint | 134,263,096 | |
TangentStart | 134,263,097 | |
TangentMiddle | 134,263,098 | |
TangentEnd | 134,263,099 | |
TangentStartExtension | 134,263,100 | |
TangentMiddleExtension | 134,263,101 | |
TangentEndExtension | 134,263,102 | |
StationExtension | 134,263,103 | |
BandTop | 134,263,104 | |
BandMiddle | 134,263,105 | |
BandBottom | 134,263,106 | |
StartExtension | 134,263,107 | |
MiddleExtension | 134,263,108 | |
EndExtension | 134,263,109 | |
Offset | 134,263,152 | |
GradeBreak | 134,263,154 | |
GradeBreakExtension | 134,263,155 |