Share

GeometryPointSelector<T> Class

This class encapsulates the functionality to allow selecting and un-selecting point types.

Inheritance Hierarchy

SystemObject
  Autodesk.CivilGeometryPointSelectorT


Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.6.1067.0

Syntax

C#

public class GeometryPointSelector<T>
where T : Enum

VB

Public Class GeometryPointSelector(Of T As Enum)

C++

generic<typename T>
where T : Enum
public ref class GeometryPointSelector

Type Parameters

T

The GeometryPointSelectorT type exposes the following members.

Constructors

 NameDescription
Public methodGeometryPointSelectorTInitializes a new instance of the GeometryPointSelectorT class

Properties

 NameDescription
Public propertyItem 

Methods

 NameDescription
Public methodSelectAll Selects all supported geometry points.
Public methodUnSelectAll Unselects all supported geometry points.

See Also

Reference

Was this information helpful?