Share

EntityNotFoundException Class

The exception that's thrown when an attempt is made to access a non-existent entity. For example, calling ProfileEntity.EntityBefore() on the first entity.

Inheritance Hierarchy

SystemObject
  SystemException
    Autodesk.CivilCivilException
      Autodesk.CivilEntityNotFoundException


Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.6.1067.0

Syntax

C#

[SerializableAttribute]
public class EntityNotFoundException : CivilException

VB

<SerializableAttribute>
Public Class EntityNotFoundException
	Inherits CivilException

C++

[SerializableAttribute]
public ref class EntityNotFoundException : public CivilException

The EntityNotFoundException type exposes the following members.

Constructors

 NameDescription
Public methodEntityNotFoundExceptionInitializes a new instance of the EntityNotFoundException class
Public methodEntityNotFoundException(ErrorStatus)Initializes a new instance of the EntityNotFoundException class
Public methodEntityNotFoundException(String)Initializes a new instance of the EntityNotFoundException class
Public methodEntityNotFoundException(ErrorStatus, String)Initializes a new instance of the EntityNotFoundException class
Public methodEntityNotFoundException(String, Exception)Initializes a new instance of the EntityNotFoundException class

See Also

Reference

Was this information helpful?