Enumerates where to anchor various label annotations.
Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.6.1067.0
Syntax
C#
public enum AnchorPointType
VB
Public Enumeration AnchorPointType
C++
public enum class AnchorPointType
Members
Member name | Value | Description |
---|---|---|
Start | 134,263,041 | |
Middle | 134,263,042 | |
End | 134,263,043 | |
TopLeft | 134,263,044 | |
TopCenter | 134,263,045 | |
TopRight | 134,263,046 | |
MiddleLeft | 134,263,047 | |
MiddleCenter | 134,263,048 | |
MiddleRight | 134,263,049 | |
BottomLeft | 134,263,050 | |
BottomCenter | 134,263,051 | |
BottomRight | 134,263,052 | |
InsertionPoint | 134,263,053 | |
Center | 134,263,054 | |
PointOfIntersection | 134,263,055 | |
Station | 134,263,072 | |
PI | 134,263,074 | |
TangentInStart | 134,263,075 | |
TangentInMiddle | 134,263,076 | |
TangentOutMiddle | 134,263,078 | |
TangentOutEnd | 134,263,079 | |
PVI | 134,263,088 | |
CurveStart | 134,263,089 | |
CurveEnd | 134,263,090 | |
PVIDimension | 134,263,091 | |
CurveStartDimension | 134,263,092 | |
CurveMidDimension | 134,263,093 | |
CurveEndDimension | 134,263,094 | |
CurveHighPoint | 134,263,095 | |
CurveLowPoint | 134,263,096 | |
TangentStart | 134,263,097 | |
TangentMiddle | 134,263,098 | |
TangentEnd | 134,263,099 | |
TangentStartDimension | 134,263,100 | |
TangentMiddleDimension | 134,263,101 | |
TangentEndDimension | 134,263,102 | |
StationExtension | 134,263,103 | |
BandTop | 134,263,104 | |
BandMiddle | 134,263,105 | |
BandBottom | 134,263,106 | |
StartExtension | 134,263,107 | |
MiddleExtension | 134,263,108 | |
EndExtension | 134,263,109 | |
PVIStart | 134,263,120 | |
PVIEnd | 134,263,121 | |
PVIStartDimension | 134,263,122 | |
PVIEndDimension | 134,263,123 | |
CurveMid | 134,263,128 | |
CurveHighPointDimension | 134,263,129 | |
CurveLowPointDimension | 134,263,130 | |
Offset | 134,263,152 | |
OffsetExtension | 134,263,153 | |
GradeBreak | 134,263,154 | |
GradeBreakExtension | 134,263,155 | |
Centerline | 134,263,156 | |
TopOuterDiameter | 134,263,157 | |
TopInnerDiameter | 134,263,158 | |
BottomOuterDiameter | 134,263,159 | |
BottomInnerDiameter | 134,263,160 | |
PipeDimension | 134,263,161 | |
StructureDimension | 134,263,162 | |
SectionViewTop | 134,263,168 | |
SectionViewBottom | 134,263,169 | |
SectionViewTopAtStart | 134,263,170 | |
SectionViewBottomAtStart | 134,263,171 | |
SectionViewTopAtMiddle | 134,263,172 | |
SectionViewBottomAtMiddle | 134,263,173 | |
SectionViewTopAtEnd | 134,263,174 | |
SectionViewBottomAtEnd | 134,263,175 | |
CurveStartInView | 134,263,184 | |
CurveEndInView | 134,263,185 | |
CurveStartInViewDimension | 134,263,186 | |
CurveEndInViewDimension | 134,263,187 | |
TangentStartInView | 134,263,188 | |
TangentEndInView | 134,263,189 | |
TangentStartInViewDimension | 134,263,190 | |
TangentEndInViewDimension | 134,263,191 | |
PVIStartInView | 134,263,192 | |
PVIEndInView | 134,263,193 | |
PVIStartInViewDimension | 134,263,194 | |
PVIEndInViewDimension | 134,263,195 | |
LabelLocation | 134,263,296 | |
SegmentMiddleSuperelevationBand | 134,264,080 | |
SegmentStartAndBandTop | 134,264,082 | |
SegmentStartAndBandMiddle | 134,264,083 | |
SegmentStartAndBandBot | 134,264,084 | |
SegmentMiddleAndBandTop | 134,264,085 | |
SegmentMiddleAndBandMiddle | 134,264,086 | |
SegmentMiddleAndBandBot | 134,264,087 | |
SegmentEndAndBandTop | 134,264,088 | |
SegmentEndAndBandMiddle | 134,264,089 | |
SegmentEndAndBandBot | 134,264,090 | |
SchematicLineStart | 134,264,091 | |
SchematicLineMid | 134,264,092 | |
SchematicLineEnd | 134,264,093 | |
PreviousOffsetBandTop | 134,264,144 | |
PreviousOffsetBandMiddle | 134,264,145 | |
PreviousOffsetBandBottom | 134,264,146 | |
NextOffsetBandTop | 134,264,150 | |
NextOffsetBandMiddle | 134,264,151 | |
NextOffsetBandBottom | 134,264,152 | |
PreviousStationBandTop | 134,264,160 | |
PreviousStationBandMiddle | 134,264,161 | |
PreviousStationBandBottom | 134,264,162 | |
LengthMidBandTop | 134,264,163 | |
LengthMidBandMiddle | 134,264,164 | |
LengthMidBandBottom | 134,264,165 | |
NextStationBandTop | 134,264,166 | |
NextStationBandMiddle | 134,264,167 | |
NextStationBandBottom | 134,264,168 | |
Insertion | 134,264,184 | |
Dimension | 134,264,185 |