Share

SurveyProjectCollection Class

This class encapsulates the read-only collection for projects. From this class, you can get the current survey project or find a specific survey project

Inheritance Hierarchy

SystemObject
  SystemMarshalByRefObject
    DisposableWrapper
      Autodesk.CivilSurveyProjectCollection


Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.6.1067.0

Syntax

C#

public sealed class SurveyProjectCollection : DisposableWrapper, 
	IEnumerable<SurveyProject>

VB

Public NotInheritable Class SurveyProjectCollection
	Inherits DisposableWrapper
	Implements IEnumerable(Of SurveyProject)

C++

public ref class SurveyProjectCollection sealed : public DisposableWrapper, 
	IEnumerable<SurveyProject^>

The SurveyProjectCollection type exposes the following members.

Properties

 NameDescription
Public propertyCount Gets the number of SurveyProject objects in the collection.
Public propertyItem 
Public propertyWorkingFolder Get or sets the working folder for survey projects.

Methods

 NameDescription
Public methodGetCurrentProject Gets the current survey project.
Public methodGetEnumerator Implements the method declared in the IEnumerable<T> interface. This method returns an enumertor which can be used to enumerate this collection.
Public methodGetItem(Guid) Find the survey project for the specified project GUID.
Public methodGetItem(String) Finds the survey project for the specified project path.
Public methodGetObjectEnumerator Implements the method declared in the IEnumerable interface. This method returns an enumertor which can be use to enumerate this collection.

See Also

Reference

Was this information helpful?