Survey project class.
Inheritance Hierarchy
SystemObjectSystemMarshalByRefObject
DisposableWrapper
Autodesk.CivilSurveyProject
Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.6.1067.0
Syntax
C#
public sealed class SurveyProject : DisposableWrapper
VB
Public NotInheritable Class SurveyProject Inherits DisposableWrapper
C++
public ref class SurveyProject sealed : public DisposableWrapper
The SurveyProject type exposes the following members.
Properties
Name | Description | |
---|---|---|
![]() | ProjectGUID | Gets the survey project guid |
![]() | ProjectName | Gets the survey project name |
Methods
Name | Description | |
---|---|---|
![]() | Close | Close this survey project |
![]() | GetSurveyQueryCollection | Gets the query collection for this survey project. |
![]() | IsOpen | returns true if this survey project is opened, else return false |
![]() | Open | Open this survey project for write or read only |