The exception that is thrown when there is an attempt to use point coordinates that do not exist. For example, calling Alignment.PointLocation() for a negative station number.
Inheritance Hierarchy
SystemObjectSystemException
Autodesk.CivilCivilException
Autodesk.CivilPointNotOnEntityException
Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.6.1067.0
Syntax
C#
[SerializableAttribute] public class PointNotOnEntityException : CivilException
VB
<SerializableAttribute> Public Class PointNotOnEntityException Inherits CivilException
C++
[SerializableAttribute] public ref class PointNotOnEntityException : public CivilException
The PointNotOnEntityException type exposes the following members.
Constructors
Name | Description | |
---|---|---|
![]() | PointNotOnEntityException | Initializes a new instance of the PointNotOnEntityException class |
![]() | PointNotOnEntityException(ErrorStatus) | Initializes a new instance of the PointNotOnEntityException class |
![]() | PointNotOnEntityException(String) | Initializes a new instance of the PointNotOnEntityException class |
![]() | PointNotOnEntityException(ErrorStatus, String) | Initializes a new instance of the PointNotOnEntityException class |
![]() | PointNotOnEntityException(String, Exception) | Initializes a new instance of the PointNotOnEntityException class |