Share

DesignCheck Class

The abstract design check class.

Inheritance Hierarchy

SystemObject
  [T:Autodesk.Civil.CivilWrapper<AcDbDatabase>]
    Autodesk.CivilDesignCheck
      Autodesk.CivilAlignmentDesignCheck
      Autodesk.CivilProfileDesignCheck


Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.6.1067.0

Syntax

C#

public abstract class DesignCheck : [T:Autodesk.Civil.CivilWrapper<AcDbDatabase>]

VB

Public MustInherit Class DesignCheck
	Inherits [T:Autodesk.Civil.CivilWrapper<AcDbDatabase>]

C++

public ref class DesignCheck abstract : public [T:Autodesk.Civil.CivilWrapper<AcDbDatabase>]

The DesignCheck type exposes the following members.

Properties

 NameDescription
Public propertyDescription Gets and sets the description of the DesignCheck.
Public propertyExpression Gets or sets the expression of the DesignCheck.
Public propertyName Gets the name of the DesignCheck.

See Also

Reference

Was this information helpful?