Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.6.1067.0
Syntax
C#
public enum SurfaceStatus
VB
Public Enumeration SurfaceStatus
C++
public enum class SurfaceStatus
Members
Member name | Value | Description |
---|---|---|
Success | 0 | |
NoSurfaceFound | 1 | |
ProcessingInterrupted | 2 | |
NoPointsInSurface | 3 | |
NoTrianglesInSurface | 4 | |
NoTriangleFound | 5 | |
PointOutsideSurface | 6 | |
TriangleIsDeleted | 7 | |
NoBorderFound | 8 | |
NoRangePointsFound | 9 | |
TrianglesAreNotNeighbors | 10 | |
NoIntersectionFound | 11 | |
DuplicatePoint | 12 | |
NoPointFound | 13 | |
Failure | 14 | |
UnimplementedOperation | 15 | |
UnableToReadFile | 16 | |
NoEdgeFound | 17 | |
EdgeIsLocked | 18 | |
CantSwap | 19 | |
LoadFailed | 20 | |
DuplicateName | 21 | |
IllegalBoundary | 22 | |
InvalidFileFormat | 23 | |
FileNotFound | 24 | |
SnapshotNotFound | 25 | |
GradingPasteToTargetSurfRejected | 26 | |
IncompatibleGrids | 27 | |
UnableToOpenSurfaceStyle | 28 | |
PointOnFlatArea | 29 | |
NeighborsNotFullySpecified | 30 | |
InconsistentNeighborPointers | 31 | |
PointsNotInCcwOrder | 32 | |
OutOfMemory | 33 | |
BaseSurfaceNotFound | 34 | |
ComparisonSurfaceNotFound | 35 |