Share

AnchorPointType Enumeration

Enumerates where to anchor various label annotations.



Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.7.0.765

Syntax

C#

public enum AnchorPointType

VB

Public Enumeration AnchorPointType

C++

public enum class AnchorPointType

Members

Member nameValueDescription
Start134,263,041 
Middle134,263,042 
End134,263,043 
TopLeft134,263,044 
TopCenter134,263,045 
TopRight134,263,046 
MiddleLeft134,263,047 
MiddleCenter134,263,048 
MiddleRight134,263,049 
BottomLeft134,263,050 
BottomCenter134,263,051 
BottomRight134,263,052 
InsertionPoint134,263,053 
Center134,263,054 
PointOfIntersection134,263,055 
Station134,263,072 
PI134,263,074 
TangentInStart134,263,075 
TangentInMiddle134,263,076 
TangentOutMiddle134,263,078 
TangentOutEnd134,263,079 
PVI134,263,088 
CurveStart134,263,089 
CurveEnd134,263,090 
PVIDimension134,263,091 
CurveStartDimension134,263,092 
CurveMidDimension134,263,093 
CurveEndDimension134,263,094 
CurveHighPoint134,263,095 
CurveLowPoint134,263,096 
TangentStart134,263,097 
TangentMiddle134,263,098 
TangentEnd134,263,099 
TangentStartDimension134,263,100 
TangentMiddleDimension134,263,101 
TangentEndDimension134,263,102 
StationExtension134,263,103 
BandTop134,263,104 
BandMiddle134,263,105 
BandBottom134,263,106 
StartExtension134,263,107 
MiddleExtension134,263,108 
EndExtension134,263,109 
PVIStart134,263,120 
PVIEnd134,263,121 
PVIStartDimension134,263,122 
PVIEndDimension134,263,123 
CurveMid134,263,128 
CurveHighPointDimension134,263,129 
CurveLowPointDimension134,263,130 
Offset134,263,152 
OffsetExtension134,263,153 
GradeBreak134,263,154 
GradeBreakExtension134,263,155 
Centerline134,263,156 
TopOuterDiameter134,263,157 
TopInnerDiameter134,263,158 
BottomOuterDiameter134,263,159 
BottomInnerDiameter134,263,160 
PipeDimension134,263,161 
StructureDimension134,263,162 
SectionViewTop134,263,168 
SectionViewBottom134,263,169 
SectionViewTopAtStart134,263,170 
SectionViewBottomAtStart134,263,171 
SectionViewTopAtMiddle134,263,172 
SectionViewBottomAtMiddle134,263,173 
SectionViewTopAtEnd134,263,174 
SectionViewBottomAtEnd134,263,175 
CurveStartInView134,263,184 
CurveEndInView134,263,185 
CurveStartInViewDimension134,263,186 
CurveEndInViewDimension134,263,187 
TangentStartInView134,263,188 
TangentEndInView134,263,189 
TangentStartInViewDimension134,263,190 
TangentEndInViewDimension134,263,191 
PVIStartInView134,263,192 
PVIEndInView134,263,193 
PVIStartInViewDimension134,263,194 
PVIEndInViewDimension134,263,195 
LabelLocation134,263,296 
SegmentMiddleSuperelevationBand134,264,080 
SegmentStartAndBandTop134,264,082 
SegmentStartAndBandMiddle134,264,083 
SegmentStartAndBandBot134,264,084 
SegmentMiddleAndBandTop134,264,085 
SegmentMiddleAndBandMiddle134,264,086 
SegmentMiddleAndBandBot134,264,087 
SegmentEndAndBandTop134,264,088 
SegmentEndAndBandMiddle134,264,089 
SegmentEndAndBandBot134,264,090 
SchematicLineStart134,264,091 
SchematicLineMid134,264,092 
SchematicLineEnd134,264,093 
PreviousOffsetBandTop134,264,144 
PreviousOffsetBandMiddle134,264,145 
PreviousOffsetBandBottom134,264,146 
NextOffsetBandTop134,264,150 
NextOffsetBandMiddle134,264,151 
NextOffsetBandBottom134,264,152 
PreviousStationBandTop134,264,160 
PreviousStationBandMiddle134,264,161 
PreviousStationBandBottom134,264,162 
LengthMidBandTop134,264,163 
LengthMidBandMiddle134,264,164 
LengthMidBandBottom134,264,165 
NextStationBandTop134,264,166 
NextStationBandMiddle134,264,167 
NextStationBandBottom134,264,168 
Insertion134,264,184 
Dimension134,264,185 

Remarks

Use for all the label style components.

See Also

Reference

Was this information helpful?