Share

SurveyQueryCollection Class

This class is to encapsulate the read only collection for MetaQuery

Inheritance Hierarchy

SystemObject
  SystemMarshalByRefObject
    DisposableWrapper
      Autodesk.CivilSurveyQueryCollection


Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.7.0.765

Syntax

C#

public sealed class SurveyQueryCollection : DisposableWrapper, 
	IEnumerable<SurveyQuery>

VB

Public NotInheritable Class SurveyQueryCollection
	Inherits DisposableWrapper
	Implements IEnumerable(Of SurveyQuery)

C++

public ref class SurveyQueryCollection sealed : public DisposableWrapper, 
	IEnumerable<SurveyQuery^>

The SurveyQueryCollection type exposes the following members.

Properties

 NameDescription
Public propertyCount Gets the number of SurveyQuery objects in the collection.
Public propertyItem 

Methods

 NameDescription
Public methodGetEnumerator Implement the method declare in IEnumerable<T> interface. This method return an enumertor which can be use to enumerate this collection.
Public methodGetItem(Guid) Find the meta query for the specified query guid.
Public methodGetItem(String) Find the meta query list for the specified query name.
Public methodGetObjectEnumerator Implement the method declare in IEnumerable interface. This method return an enumertor which can be use to enumerate this collection.

See Also

Reference

Was this information helpful?