Share

SurveyProject Class

Survey project class.

Inheritance Hierarchy

SystemObject
  SystemMarshalByRefObject
    DisposableWrapper
      Autodesk.CivilSurveyProject


Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.7.0.765

Syntax

C#

public sealed class SurveyProject : DisposableWrapper

VB

Public NotInheritable Class SurveyProject
	Inherits DisposableWrapper

C++

public ref class SurveyProject sealed : public DisposableWrapper

The SurveyProject type exposes the following members.

Properties

 NameDescription
Public propertyProjectGUID Gets the survey project guid
Public propertyProjectName Gets the survey project name

Methods

 NameDescription
Public methodClose Close this survey project
Public methodGetSurveyQueryCollection Gets the query collection for this survey project.
Public methodIsOpen returns true if this survey project is opened, else return false
Public methodOpen Open this survey project for write or read only

See Also

Reference

Was this information helpful?