| Class | Description |
---|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | AlignmentDesignCheckSet |
A collection of alignment design checks, which can be applied to an alignment.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | AlignmentDesignCheckSetCollection |
The AlignmentDesignCheckSetCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | AlignmentLabelSetItem |
The predefined label properties for alignments.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | AlignmentLabelSetStyle |
The predefined label properties for stations, lines, and curves.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | AlignmentLabelSetStyleCollection |
The AlignmentLabelStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | AlignmentStyle |
Specifies properties for the various alignment components.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | AlignmentStyleCollection |
A collection of AlignmentStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ArrowHeadOption |
Display options for arrows in AlignmentStyle and ProfileStyle.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) ![Code example Code example](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/CodeExample.png) | AssemblyStyle |
Used to control the visual style of an Assembly object.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | AssemblyStyleCollection |
A collection of AssemblyStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | AxisStyle |
Controls the use of tick marks on the horizontal and vertical axes of the profile view or cross section view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | AxisTickStyle |
Controls the title location and display on the horizontal and vertical axes of the profile view or cross section view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | AxisTitleStyle |
The AxisTitleStyle class, which defines the text, text style, size etc. of an axis title.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | BandSetItem |
This class encapsulates a single view data band, serves as a base class for the band item in the profile/section view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | BandSetItemCollection |
This class stores all the band items, serves as a base class for the profile/section view band items collection.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | BandSetStyle |
This class serves as a base class for the profile/section bandset style.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | BandStyle |
Specifies style properties for data bands, the graphic frames that are associated with a profile view object or section view object.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | BandStyleCollection |
A collection of BandStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | BandStylesRoot |
The root object that contains collections of the various band styles in a document.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | BandStylesRootPressurePipesExtension |
This extension class extends the interface of BandStylesRoot to provide
methods related to pressure pipes.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | BandTickStyle |
Specifies the type and location of ticks for profile or section view data bands.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | BaseLabelSetItem |
The base class for alignment label set items.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | BaseLabelSetStyle |
The base class for alignment label set styles.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | BuildingSiteStyle |
Display options for building site objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | BuildingSiteStyleCollection |
A collection of BuildingSiteStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | CantViewStyle |
The class to describe CantView object style.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | CantViewStyleCollection |
The CantViewStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | CatchmentStyle |
Defines how a catchment area appears in plan view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | CatchmentStyleCollection |
A collection of CatchmentStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) ![Code example Code example](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/CodeExample.png) | CodeSetStyle |
A collection of CodeSetStyleItem objects.
CodeSetStyleItem defines a code and related style, where the style is the ObjectId of a LinkStyle or ShapeStyle.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | CodeSetStyleCollection |
A collection of CodeSetStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | CodeSetStyleItem |
Defines the style to apply to a specific code.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ColumnStyle |
Defines column width and value properties for table style objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ColumnStyleCollection |
A collection of ColumnStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ContourValues |
Defines how to display major and minor contour lines; used by the SurfaceContourStyle class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | CorridorStyle |
Defines the appearance of objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | CorridorStyleCollection |
A collection of CorridorStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | DataPartFamily |
Part family data that is queried from the catalog.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | DisplayStyle |
Specifies display properties for the style, such as layer, color, and linetype.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | Expression |
Encapsulates an expression used in label styles.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ExpressionCollection |
A collection of Expression objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | FeatureLineStyle |
Specifies default display and other characteristics for feature line features when they are created.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | FeatureLineStyleCollection |
A collection of FeatureLineStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | GradingCriteria |
Specifies grading criteria (a projection method and target) to create a finished grading surface.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | GradingCriteriaSet |
A set of multiple related GradingCriteria objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | GradingCriteriaSetCollection |
A collection of GradingCriteriaSet objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | GradingStyle |
Specifies default display and other characteristics for grading features when they are created.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | GradingStyleCollection |
A collection of GradingStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | GraphStyle |
Specifies format and contents of the title, vertical exaggeration, and grid options for graphs.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | GraphTitleStyle |
Specifies display characteristics for profile and section view graphs.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | GridOptions |
Specifies various grid options used by GridStyle.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | GridStyle |
Specifies display characteristics for profile and section view graph gridlines.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | GroupPlotStyle |
Specifies section view group plot style settings.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | GroupPlotStyleCollection |
A collection of GroupPlotStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | HatchDisplayStyle |
Represents the hatch display properties for a component (such as parcels).
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | HorizontalGeometryBandStyle |
The style object specifying characteristics for profile view horizontal geometry data bands.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) ![Code example Code example](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/CodeExample.png) | InterferenceStyle |
Defines how a pipe interference appears in plan, profile, section, and 3D view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | InterferenceStyleCollection |
A collection of InterferenceStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | IntersectionStyle |
The match line style wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | IntersectionStyleCollection |
The IntersectionStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelSetStylesRoot |
The root object for accessing label set style collections in the database.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyle |
The master label style class, containing feature-specific label styles and associated information such as derived styles.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleBase |
Base class for label style defaults.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleBaseBaseBehavior |
The behavior related properties of the default label style.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleBaseBaseDraggedStateComponents |
The dragged state components related properties of the default label style.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleBaseBaseLabel |
The label related properties of the default label style.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleBaseBaseLeader |
The leader related properties of the default label style.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleBaseBasePlanReadability |
The plan readability related properties of the default label style.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleBlockComponent |
The lable style text component wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleBlockComponentStyleBlock | Block style settings for label block components. |
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleBlockComponentStyleGeneral | General style settings for label block components. |
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleCollection |
A collection of LabelStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleComponent |
The lable style component wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleDefault |
The settings class for the label style default.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleDefaultDefaultBehavior |
The behavior related properties of the default label style settings.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleDefaultDefaultComponents |
The component related properties of the default label style settings.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleDefaultDefaultDraggedStateComponents |
The dragged state components related properties of the default label style settings.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleDefaultDefaultLabel |
The label related properties of the default label style settings.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleDefaultDefaultLeader |
The leader related properties of the default label style settings.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleDefaultDefaultPlanReadability |
The plan readability related properties of the default label style settings.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleDirectionArrowComponent |
The lable style direction arrow component wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleDirectionArrowComponentStyleDirectionArrow | Direction arrow style settings for label direction arrow components. |
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleDirectionArrowComponentStyleGeneral | General style settings for label direction arrow components. |
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleLineComponent |
The lable style line component wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleLineComponentStyleGeneral | General style settings for line labels. |
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleLineComponentStyleLine | Line style settings for line labels. |
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleReferenceTextComponent |
The lable style reference text component wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleReferenceTextComponentStyleGeneral | General style settings for label reference text components. |
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesAlignmentRoot |
All Alignment-related label styles. These styles control the label display for alignment components, such as major and minor stations, station equations, geometry points, and so on.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesCatchmentRoot |
LabelStylesCatchmentRoot
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesIntersectionRoot |
Root for all intersection label collections.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesMatchLineRoot |
All styles associated with match line labels.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesNode |
Base class for root label style classes, such as LabelStylesAlignmentRoot.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesParcelRoot |
LabelStylesParcelRoot
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesPipeRoot |
Root object for pipe label styles.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesPointRoot |
LabelStylesPointRoot
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesPressureAppurtenanceRoot |
This class defines the root for appurtenance label styles.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesPressureFittingRoot |
This class defines the root for fitting label styles.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesPressurePipeRoot |
This class defines the root for pressure pipe label styles.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesProfileRoot |
LabelStylesProfileRoot
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesProfileViewRoot |
LabelStylesProfileViewRoot
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesProjectionRoot |
LabelStylesProjectionRoot
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesRoot |
Root object for accessing all label styles in a CivilDocument.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesRootPressurePipesExtension |
This extension class extends the interface of LabelStylesRoot to provide
methods related to pressure pipes.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesSampleLineRoot |
LabelStylesSampleLineRoot
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesSectionRoot |
LabelStylesSectionRoot
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesSectionViewRoot |
LabelStylesSectionViewRoot
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesStructureRoot |
Root object for structure label styles.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesSurfaceRoot |
LabelStylesSurfaceRoot
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesSurveyRoot |
LabelStylesSurveyRoot
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStylesViewFrameRoot |
LabelStylesViewFrameRoot
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleTextComponent |
Specifies the appearance and behavior of text feature labels in the drawing. Controls the appearance of the text itself.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleTextComponentStyleBorder | Border style settings for label text components. |
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleTextComponentStyleGeneral | General style settings for label text components. |
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleTextComponentStyleText | Text style settings for label text components. |
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleTextForEachComponent |
The lable style reference text component wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleTextForEachComponentStyleBorder | |
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleTextForEachComponentStyleGeneral | General style settings for text-for-each label components. |
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleTextForEachComponentStyleText | |
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleTickComponent |
The lable style tick component wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleTickComponentStyleGeneral | General style settings for label tick components. |
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LabelStyleTickComponentStyleTick | Tick style settings for label tick components. |
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) ![Code example Code example](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/CodeExample.png) | LinkStyle |
Used to control the visual style of a roadway link (Link) object.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | LinkStyleCollection |
A collection of LinkStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | MarkerStyle |
Sets the style of a marker. Markers are used to mark locations along Alignment objects or survey figures (SurveyFigure), and can also used to indicate interferences in pipe networks (InterferenceChecks).
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | MarkerStyleBase |
The base class for marker and point styles.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | MarkerStyleCollection |
A collection of MarkerStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | MassHaulLineStyle |
The view frame style wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | MassHaulLineStyleCollection |
The MassHaulLineStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | MassHaulViewStyle |
The view frame style wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | MassHaulViewStyleCollection |
The MassHaulViewStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | MatchLineStyle |
The match line style wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | MatchLineStyleCollection |
The MatchLineStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | NetworkRuleSetStyle |
Base class for Pipe and Structure rule sets.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ParcelStyle |
The parcel style wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ParcelStyleCollection |
The ParcelStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PartFamily |
Each Part is a member of a PartFamily containing all size variations for a given part.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) ![Code example Code example](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/CodeExample.png) | PartSize |
Pipe network part size filter.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PartsList |
List of pipe network parts (pipes and structures) used for a particular drawing.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PartsListCollection |
A collection of PartsList objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PipeNetworkBandStyle |
Band style in pipe network profile views.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PipeRuleSetStyle |
A set of rules for pipe objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PipeRuleSetStyleCollection |
A collection of PipeRuleSetStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PipeStyle |
Defines how a pipe appears in plan, profile, section, and 3D view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PipeStyleCollection |
A collection of PipeStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PipeStyleOptionBase |
Base interface for settings that define the appearance of the pipe in a 2D plan view. Used by PipeStylePlanOption and PipeStyleProfileOption.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PipeStylePlanOption | Settings that define the appearance of the pipe in a 2D plan view. |
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PipeStyleProfileOption |
Settings that define the appearance of the pipe in a profile view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PointCloudClassificationInfo |
The PointCloudClassificationInfo class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PointCloudClassificationInfoCollection |
The PointCloudClassificationInfoCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PointCloudPointStyle |
The PointCloudPointStyle class is used to specify the size, number, and color of the point cloud points.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PointCloudStyle |
The class to describe point cloud object style.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PointCloudStyleCollection |
The PointCloudStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PointStyle |
The point style class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PointStyleCollection |
The PointStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PressureAppurtenanceStyle |
This class defines how an appurtenance appears in plan, profile and model view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PressureAppurtenanceStyleCollection |
This class defines the collection of PressureAppurtenanceStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PressureAppurtenanceStylePlanOption |
This class specifies the method that is used to define and draw the dimensions
of an appurtenance in 2D plan view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PressureFittingStyle |
This class defines how a fitting appears in plan, profile and model view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PressureFittingStyleCollection |
This class defines the collection of PressureFittingStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PressureFittingStylePlanOption |
This class specifies the method that is used to define and draw the dimensions
of a fitting in 2D plan view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PressureNetworkBandStyle |
The pressure network profile band style wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PressurePartList |
This class defines the list of pressure network parts (pipes, fittings and appurtenances)
used to layout pressure networks.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PressurePartListCollection |
This class defines the collection of PressurePartList objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PressurePartSize |
This class defines the pressure part information used to specify a particular pressure part.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PressurePipeStyle |
This class defines how a pressure pipe appears in plan, profile and model view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PressurePipeStyleCollection |
This class defines the collection of PressurePipeStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PressurePipeStylePlanOption |
This class defines the settings that define the appearance of a pressure pipe in 2D plan view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | PressurePipeStyleProfileOption |
This class defines the settings that define the appearance of a pressure pipe in 2D profile view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ProfileDataBandStyle |
The profile data band style wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ProfileDesignCheckSet |
A collection of profile design checks, which can be applied to an alignment.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ProfileDesignCheckSetCollection |
The AlignmentStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ProfileLabelSetItem |
Predefined label properties for profiles.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ProfileLabelSetStyle |
The profile lable set wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ProfileLabelSetStyleCollection |
The ProfileLabelStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ProfileStyle |
The profile style wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ProfileStyleCollection |
The ProfileStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ProfileViewBandSetItem |
Encapsulates a single profile view data band.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ProfileViewBandSetItemCollection |
This class represents a collection that stores all the band items for a profile view bandset style object.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ProfileViewBandSetStyle |
This class represents a profile view band set style object.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ProfileViewBandSetStyleCollection |
The ProfileViewBandSetStyleCollection wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ProfileViewStyle |
The profile view style wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) ![Code example Code example](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/CodeExample.png) | ProfileViewStyleCollection |
The ProfileViewStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ProjectionProfileOptions |
Contains display options and styles for objects projected from a plan view onto a profile view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ProjectionSectionOptions |
Contains display options and styles for objects projected from a plan view onto a section view.
Used by ProjectionStyle.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ProjectionStyle |
Contains display options and styles for objects projected from a plan view onto a section or profile view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ProjectionStyleCollection |
A collection of ProjectionStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | QuantityTakeoffCriteria |
A collection of items that define the criteria used to calculate material lists, which are
then used ot generate quantity takeoff tables and reports.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | QuantityTakeoffCriteriaCollection |
The QuantityTakeoffCriteriaCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | QuantityTakeoffCriteriaData |
Defines additional data for material in QuantityTakeoffCriteria.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | QuantityTakeoffCriteriaItem |
Defines a material used to create quantity takeoff criteria (QuantityTakeoffCriteria).
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SampleLineStyle |
Specifies display properties for the sample lines used to obtain elevational information from an existing terrain model or surface.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SampleLineStyleCollection |
The SampleLineStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SectionalDataBandStyle |
The section data band style wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SectionDataBandStyle |
The section data band style wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SectionLabelSetItem |
A collection of properties used to ensure that labels associated with sections are consistent and to ensure that labels used elsewhere contain distinguishing content.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SectionLabelSetStyle |
The section labelset wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SectionLabelSetStyleCollection |
The SectionLabelStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SectionSegmentBandStyle |
The section data band style wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SectionStyle |
Specifies display characteristics and associated information for cross sections and their constituent components.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SectionStyleCollection |
The SectionStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SectionViewBandSetItem |
Encapsulates a single section view data band.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SectionViewBandSetItemCollection |
The SectionViewBandSetItemCollectione wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SectionViewBandSetStyle |
The SectionViewBandSetStyle wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SectionViewBandSetStyleCollection |
The SectionViewBandSetStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SectionViewStyle |
The section view style wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SectionViewStyleCollection |
The SectionViewStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SegmentColumnStyle |
Specifies the advance column style obtained from the Parcel Segment table style or Alignment Segment table style.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) ![Code example Code example](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/CodeExample.png) | ShapeStyle |
Used to control the visual style of various roadway shape objects. Also used to style ProfileView ProfileHatchArea objects. ShapeStyle objects defined for a drawing are kept in the
CivilDocument::Styles::ShapeStyles collection.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ShapeStyleCollection |
A collection of ShapeStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SheetStyle |
The sheet plot style applied when plot by page is selected.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SheetStyleCollection |
The SheetStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SizeFilterField |
Part size parameters from a SizeFilterRecord.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SizeFilterRecord |
Lets users specify what part sizes they want to add into a part family.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SlopePatternComponent |
Encapsulates the properties of slope pattern components used to make up a SlopePatternStyle.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SlopePatternLine |
Defines a line used in a SlopePatternComponent.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SlopePatternLineOffset |
Defines the offset of lines in a SlopePatternComponent.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SlopePatternLineSymbol |
Defines the symbol used with a SlopePatternComponent.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SlopePatternStyle |
A style that defines the pattern that represents a slope in a grading style.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SlopePatternStyleCollection |
The SlopePatternStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | StructureColumnComponentData |
Specifies the table cell component data information.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | StructureColumnComponents | |
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | StructureColumnStyle |
Specifies the advance column style obtained from the Structure table style.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | StructureRuleSetStyle |
A set of rules for structure objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | StructureRuleSetStyleCollection |
A collection of StructureRuleSetStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | StructureStyle |
Specifies display properties for all structure objects in the drawing.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | StructureStyleCollection |
A collection of StructureStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | StructureStyleModelOption |
Specifies the method that is used to define and draw the dimensions of the structure in model view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | StructureStyleOptionBase |
Base class for StructureStyleProfileOption and StructureStyleSectionOption.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | StructureStylePlanOption |
Specifies the method that is used to define and draw the dimensions of the structure in 2D plan view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | StructureStyleProfileOption |
Specifies the method that is used to define and draw the dimensions of the structure in profile view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | StructureStyleSectionOption |
Specifies the method that is used to define and draw the dimensions of the structure in section view.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | StyleBase |
The base class for all style objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | StyleCollectionBase |
The base class for all style collections.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | StylesRoot |
The root class for accessing collections of all Civil 3D styles.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | StylesRootPressurePipesExtension |
This extension class extends the interface of StylesRoot to provide methods
related to pressure pipes.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SubassemblySubentityStyle |
Base class for LinkStyle and ShapeStyle.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SuperelevationDataBandStyle |
The super elevation data band style wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SuperelevationViewStyle |
The class to describe superelevation object style.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SuperelevationViewStyleCollection |
The SuperelevationViewStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurfaceBaseStyle |
The surface base style class
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurfaceBoundaryStyle |
The surface boundary style class
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurfaceContourStyle |
The surface boundary style class
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurfaceDirectionStyle |
The surface boundary style class
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurfaceElevationStyle |
The surface boundary style class
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurfaceGridStyle |
The SurfaceGridStyle class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurfaceHatchInfo |
The SurfaceHatchInfo class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurfacePointStyle |
The SurfacePointStyle class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurfaceSlopeArrowStyle |
The SurfaceSlopeArrowStyle class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurfaceSlopeStyle |
The SurfaceSlopeStyle class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurfaceStyle |
The surface style class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurfaceStyleCollection |
The SurfaceStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurfaceTriangleStyle |
The SurfaceTriangleStyle class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurfaceWatershedStyle |
The SurfaceWatershedStyle class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurveyFigureStyle |
The survey figure style class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurveyFigureStyleCollection |
The SurveyStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurveyNetworkStyle |
The alignment style wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | SurveyNetworkStyleCollection |
The SurveyNetworkStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | TableStyle |
Controls the display of tables.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | TableStyleCollection |
A collection of TableStyle objects.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | TableStylesRoot |
The root object of all Civil 3D table-related styles.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | TableStylesRootPressurePipesExtension |
This extension class extends the interface of TableStylesRoot to provide methods
related to pressure pipes.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | VerticalGeometryBandStyle |
The vertical geometry band style wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ViewFrameStyle |
The view frame style wrapper class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | ViewFrameStyleCollection |
The ViewFrameStyleCollection class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | WatershedBaseStyle |
The WatershedBaseStyle class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | WatershedBoundaryPointStyle |
The WatershedBoundaryPointStyle class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | WatershedBoundarySegmentStyle |
The WatershedBoundaryPointStyle class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | WatershedDepressionStyle |
The WatershedBoundaryPointStyle class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | WatershedDrainPointSegmentStyle |
This class is to specify the display drain target point and segments for the watershed.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | WatershedDrainPointStyle |
This class is to specify the display drain target points for the watershed.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | WatershedDrainSegmentStyle |
This class is to specify the display drain target segments for the watershed.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | WatershedFlatAreaStyle |
The WatershedBoundaryPointStyle class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | WatershedMultipleDrainNotchStyle |
The WatershedBoundaryPointStyle class.
|
![Public class Public class](https://help.autodesk.com/cloudhelp/2025/ENU/Civil3D-API/icons/pubClass.gif) | WatershedMultipleDrainStyle |
The WatershedBoundaryPointStyle class.
|