Share

AlignmentDesignCheckRoot Class

The AlignmentDesignCheckRoot class.

Inheritance Hierarchy

SystemObject
  Autodesk.CivilAlignmentDesignCheckRoot


Namespace: Autodesk.Civil
Assembly: AeccDbMgd (in AeccDbMgd.dll) Version: 13.7.0.765

Syntax

C#

public class AlignmentDesignCheckRoot

VB

Public Class AlignmentDesignCheckRoot

C++

public ref class AlignmentDesignCheckRoot

The AlignmentDesignCheckRoot type exposes the following members.

Constructors

 NameDescription
Public methodAlignmentDesignCheckRoot Constructor of AlignmentDesignCheckRoot class.

Properties

 NameDescription
Public propertyCurveDesignChecks Gets the collection of all alignment curve design checks.
Public propertyLineDesignChecks Gets the collection of all alignment line design checks.
Public propertySpiralDesignChecks Gets the collection of all alignment spiral design checks.
Public propertySuperelevationDesignChecks Gets the collection of all alignment superelevation design checks.
Public propertyTangentIntersectionDesignChecks Gets the collection of all alignment tangent intersection design checks.

See Also

Reference

Was this information helpful?