Issue:
When synchronizing a file to Forma Data Management (Formerly Autodesk Docs) or BIM 360 Document Management in Collaboration for AutoCAD and Civil 3D, the sync does not complete and no changes are recorded in Forma Data Management or BIM 360 Docs. When opening the same file in AutoCAD or Civil 3D, an older version may be opened that does not contain the latest changes.
For other files, syncing works fine.
Causes:
There are several known causes:
- The requirements to access Collaboration have not been met.
- An issue with backup (.bak) files going Read-only and preventing successful saves.
- The file does not follow best practices for reference management within Collaboration for AutoCAD and Civil 3D.
- The file contains or references a file that contains an unsupported file type within Collaboration for AutoCAD and Civil 3D.
- Another software is interfering with the Desktop Connector.
- Internet connection issues.
- The file is corrupt.
- The Windows User profile is corrupt.
- A reference limit has been hit on the file that you are trying to sync or one of its references.
Solution:
First confirm that you have been set up correctly to access Collaboration for AutoCAD and Civil 3D. See How Do I Access Autodesk Collaboration for Civil 3D?
Once confirmed, try to sync again by following these steps:
- Review the Desktop Connector's Pending Actions. If there are Failed Actions for that file, reapply the most recent. Clear out any older Actions on that file.
- Browse to the file's location on the Connected Drive in Windows File Explorer. You may see the file in a "Modified" status, indicating local changes have not been synced yet. Right-click on the file>Sync.
- If present, delete the .bak file and try to Sync again. If this works, you can use the MOVEBAK command to permanently change where these files are stored.
Notes:
- For files in a "New" status that haven't been uploaded to Forma Data Management yet, you will not be able to manually Sync them in Windows File Explorer. Alternatively, open the file and perform another save.
- With the AutoCAD 2022.1 update, .bak files are no longer automatically generated when saving in Forma Data Management so Step 3 above should not be necessary. See Backup files (BAK) are not created when saving an AutoCAD drawing to Forma Data Management.
If syncing continues to fail, try the following solutions:
- Sync drawings in File Explorer before opening them to confirm version being accessed. If the drawing does not sync, Free Up space and sync again (How to clear the cache of the Forma Data Management Desktop Connector to free up local disk space).
- As a test, Save As and remove all references. If this new file Syncs successfully, the issue is likely related to reference pathing. Review and apply the best practices and recommendations regarding reference paths in the following articles:
- If you see an error in the Desktop Connector Pending Actions indicating the sync is failing due to another file that cannot be accessed, see "Unable to save to drawing as it is being accessed by another session" when saving a DWG file in Civil 3D through Desktop Connector.
- Check for unsupported file types in the file, its references, and the source drawings of its data shortcuts. See File Type Limitations for Collaboration for Civil 3D.
- Test disabling anti-virus or other company software that might interfere. A list of Known Conflicting Software can be found here: Known Conflicting Software
- If connecting over a VPN, test off the VPN. See Performance issues while working with Collaboration for Civil 3D over a VPN.
- Repair the file. See How to repair corrupt AutoCAD files. It may be easier to download the file to a local location to do the repair and then reupload it.
- If you see a Failed Desktop Connector action that mentions a "Relationship Inbound Limit", see: "Failed - Action required" or "RELATIONSHIP_INBOUND_LIMIT_EXCEEDED" when trying to sync or save DWGs to Docs through Desktop Connector
- Login with a different Windows user credentials and test if the sync is successful and saves all the latest changes. If yes, contact your system admin to re-create your Windows user profile to clear corruptions in profile if any.
Note: If your file fails to sync and a team member makes changes to that same file and successfully syncs, your file will be placed in a "Conflict" status and your work is at risk of being lost. See Losing data when working with DWG files in Desktop Connector for how to address this.
See Also:
- General slow performance when opening and saving Civil 3D drawings through Desktop Connector
- File locking is not working as expected when using Collaboration for Civil 3D
- Not getting reference notifications when working in files in Collaboration for Civil 3D
- Civil 3D data shortcuts fail to be created in BIM 360 followed by Failed Pending Actions in Desktop Connector
