Share

Files are not completely synchronizing to Forma Data Management in Collaboration for AutoCAD and Civil 3D

Technical Support

Issue:

When synchronizing a file to Forma Data Management (Formerly Autodesk Docs) or BIM 360 Document Management in Collaboration for AutoCAD and Civil 3D, the sync does not complete and no changes are recorded in Forma Data Management or BIM 360 Docs. When opening the same file in AutoCAD or Civil 3D, an older version may be opened that does not contain the latest changes. 

For other files, syncing works fine. 

Causes:

There are several known causes:

  • The requirements to access Collaboration have not been met.
  • An issue with backup (.bak) files going Read-only and preventing successful saves.
  • The file does not follow best practices for reference management within Collaboration for AutoCAD and Civil 3D.
  • The file contains or references a file that contains an unsupported file type within Collaboration for AutoCAD and Civil 3D.
  • Another software is interfering with the Desktop Connector.
  • Internet connection issues.
  • The file is corrupt.
  • The Windows User profile is corrupt.
  • A reference limit has been hit on the file that you are trying to sync or one of its references.

Solution:

First confirm that you have been set up correctly to access Collaboration for AutoCAD and Civil 3D. See How Do I Access Autodesk Collaboration for Civil 3D?

Once confirmed, try to sync again by following these steps:

  1. Review the Desktop Connector's Pending Actions. If there are Failed Actions for that file, reapply the most recent. Clear out any older Actions on that file.
  2. Browse to the file's location on the Connected Drive in Windows File Explorer. You may see the file in a "Modified" status, indicating local changes have not been synced yet. Right-click on the file>Sync. 
  3. If present, delete the .bak file and try to Sync again. If this works, you can use the MOVEBAK command to permanently change where these files are stored.

Notes:

  • For files in a "New" status that haven't been uploaded to Forma Data Management yet, you will not be able to manually Sync them in Windows File Explorer. Alternatively, open the file and perform another save.
  • With the AutoCAD 2022.1 update, .bak files are no longer automatically generated when saving in Forma Data Management so Step 3 above should not be necessary. See Backup files (BAK) are not created when saving an AutoCAD drawing to Forma Data Management.

If syncing continues to fail, try the following solutions: 

Note: If your file fails to sync and a team member makes changes to that same file and successfully syncs, your file will be placed in a "Conflict" status and your work is at risk of being lost. See Losing data when working with DWG files in Desktop Connector for how to address this.

Products:

AutoCAD; Civil 3D; Desktop Connector; Forma Design Collaboration; Forma Data Management; BIM 360 Docs;

Was this information helpful?