Share

Exporting Pipe Network Data to an .stm File

Product Documentation
Intermediate

You can export pipe network data from AutoCAD Civil 3D to an .stm file.

The .stm file can then be opened bythe Hydraflow Storm Sewers exstension for analysis and editing. After editing the file in Storm Sewers, you can import it back into AutoCAD Civil 3D. Changes made to the file while in the Storm Sewers extention are recognized in AutoCAD Civil 3D.

You can export one or more pipe networks into an .stm file. You must choose entire pipe networks. You cannot export individual parts, or a set of connected parts within a pipe network.

It is important to note the following before exporting pipe networks to an .stm file (or any type of export of pipe data):

  • If a pipe does not have an upstream structure in AutoCAD Civil 3D, it is given a null structure in the exported file.
  • If a structure is not attached to a pipe, the structure will not be exported.
Note

You cannot open .stm files that were exported from AutoCAD Civil 3D, or that were saved in the Storm Sewers Extension for Civil 3D 2010, in the Storm Sewers Extension for Civil 3D 2009, or earlier versions of the Storm Sewers Extension.

To export an .stm file from AutoCAD Civil 3D

  1. Do one of the following:
    • In the drawing, select a pipe network. On the Pipe Networks tab, click the Analyze tabStorm Sewers drop-down Export To File.
    • Click the Output tabExport panel Export To File.
    • In Toolspace, on the Prospector tab, right-click the Pipe Networks collection, or right-click the pipe network you want to export, and then select Export to Storm Sewers.
    • At the command line, enter ExportStormSewerData.
  2. On the Export to Storm Sewers dialog box, specify the pipe networks to be exported, and then click OK.
  3. On the Export Storm Sewers to File dialog box, specify the location and the name for the .stm file, and then click Save.

To export an .stm file from AutoCAD Civil 3D and open it in Storm Sewers for editing

  1. Do one of the following:
    • In the drawing, select a pipe network. From the Pipe Networks tab Analyze panelStorm Sewers drop-down Edit In Storm Sewers.
    • At the command line, enter EditInStormSewers.
  2. On the Export to Storm Sewers dialog box, specify the pipe networks to be exported, and then click OK.
  3. On the Export Storm Sewers to File dialog box, specify the location and the name for the .stm file, and then click Save.

Ribbon

Output tab Export panel Export To Storm Sewers

Or

Pipe Networks contextual tab Analyze panelStorm Sewers drop-down Export to File

Menu

File menu ExportExport Data To Storm Sewers

Toolspace Context Menu

Prospector tab: right-click pipe network Export to Storm Sewers

Command Line

ExportStormSewers

Dialog Box


Was this information helpful?