Share

Sharing Subassemblies

Product Documentation
Intermediate

You can access and share subassemblies using tool palettes, the AutoCAD Civil 3D Corridor Modeling catalogs, or package files.

For example, you can create custom subassemblies in your drawing, and then drag and drop them onto a tool palette or catalog. You can create a tool palette or catalog that contains multiple custom subassemblies and then share that tool palette or catalog with others.

Custom subassemblies that have been created using .NET or VBA can be exported and imported using a package file. Subassemblies created from polylines cannot be included in a package file.

A package file contains all the files necessary for the custom subassemblies to work. Once the package file is created, users can import the package file contents into AutoCAD Civil 3D using the ImportSubassemblies command, and copy the custom subassemblies directly into a tool palette or catalog. You can also share a package file with others. For example, you could attach a package file containing one or more subassemblies to an e-mail, or use other file transfer methods.

For more information on creating package files, see "Exporting Custom Subassemblies Using a Package File" in the Developer's Guide.

For information on adding subassemblies to tool palettes, see Tool Palettes.

To copy (import) subassemblies from a package file to a tool palette

  1. To display the Tool Palettes window:

    Click Home tabPalettes panel.At the Command prompt, enter toolpalettes.

  2. Open the tool palette that you want to copy the subassemblies into. You may open an existing tool palette or create a new one.
  3. Click Insert tabImport panelImport Subassemblies.At the Command prompt, enter ImportTools.
  4. On the Import Subassemblies dialog box, click the folder icon to navigate to and select the package file.
  5. In the Import To section, click Tool Palette, and then select the desired tool palette in the drop-down list.
    Note

    You can import the subassemblies to a tool palette and to a catalog at the same time. When you import subassemblies to a catalog, they automatically get imported to the My Imported Tools catalog. If the My Imported Tools catalog does not exist, it is automatically created.

  6. Click OK.

The subassemblies contained in the package file are copied to the tool palette. If you chose to copy the subassemblies to a catalog at the same time, the subassemblies are also copied to the My Imported Tools catalog.

Note

Subassemblies created from polylines cannot be included in a package file. Package files are intended for sharing custom subassemblies that have been created using .NET or VBA.

To copy (import) subassemblies from a package file to a catalog

  1. To display the corridor modeling catalogs:

    Click View tabPalettes panel.At the Command prompt, enter contentbrowser.

    Tip

    When working with both the AutoCAD Civil 3D workspace and the Content Browser, you may find it useful to have the Content Browser window displayed at all times. To do this, right-click in the Content Browser title bar and select Always On Top.

  2. Click Insert tabImport panelImport Subassemblies.At the Command prompt, enter ImportTools.
  3. On the Import Subassemblies dialog box, click the folder icon to navigate to and select the package file.
  4. In the Import To section, click Catalog Library/My Imported Tools.
    Note

    You can import the subassemblies to a tool palette and to a catalog at the same time. When you import subassemblies to a catalog, they automatically get imported to the My Imported Tools catalog. If the My Imported Tools catalog does not exist, it is automatically created.

  5. Click OK.

The subassemblies contained in the package file are copied to the My Imported Tools catalog.

Note

When you import subassemblies to a catalog using this method (package files), you can only copy the subassemblies to the My Imported Tools catalog. If the My Imported Tools catalog does not exist, one is automatically created. Once the subassemblies are in the My Imported Tools catalog, you can then copy them to other catalogs.

If you chose to copy the subassemblies to a tool palette at the same time, the subassemblies are also copied to the selected tool palette.

Note

Subassemblies created from polylines cannot be included in a package file. Package files are intended for sharing custom subassemblies that have been created using .NET or VBA.

Ribbon

Insert tab Import panel Import Subassemblies

Menu

Corridors menu UtilitiesImport Subassemblies

Tool Palette Context Menu

In Tool Palette: Right-click Import Subassemblies

Command Line

ImportTools

Dialog Box


Was this information helpful?