Share

Editing Feature Line Curves

Product Documentation
Intermediate

Use the Edit Curve command to edit the radius of feature line (or survey figure) arcs.

When the radius is changed, the new arc is displayed and the existing arc is indicated with dashed highlighting.

To edit feature line curves

  1. Click Modify tabEdit Geometry panelEdit Curve.
  2. Select the curve to edit. The curve is highlighted, and the points are displayed.
  3. In the Edit Feature Line Curve dialog box, edit the curve. Use the Radius edit box to specify the radius.
  4. Use the Maintain Tangency option to control the curve tangency state.

    The curve is highlighted and the arc start, center and end points are displayed with glyphs.

    When the radius is changed, if the arc is tangent to the segments on either side, the tangency is maintained. Before selecting OK in the Edit Feature Line Curve dialog box, the new arc is displayed. At the same time, the existing arc remains visible with the dashed highlighting.

    The start and end points remain constant if the arc is not tangent.

    If the arc is not tangent, the start and end points of the arc are held when the radius is changed.

    If the curve is not tangent, the Maintain Tangency button is activated. If you toggle this button the curve will be adjusted to make it tangent to the adjacent segments. If the curve is tangent, the button is disabled.

    Note

    When the Delete option is selected, the segments on either side of the curve are extended to an intersection point.

    Segments extend to intersection point.

Ribbon

Click Modify tabEdit Geometry panelEdit Curve

Menu

Grading menu Edit Feature Line GeometryEdit Curve

Command Line

EditFeatureCurve

Supported Objects

  • Feature lines
  • Survey figures
  • 3D polylines
  • 2D polylines
  • Lines


Was this information helpful?