Remote Queue offline
Problem
A remote machine that was added in the Analyze dialog displays the message offline.
Cause
The Simulation Compute Manager service is not running correctly on the remote machine.
Port 43100 or 44200 is not open on the remote machine.
What to do
To check the service is running on the remote machine:
Windows:
- Open the Windows Services application.
- Click on Autodesk Simulation Compute Manager.
- If the Status is not shown as Running, restart the service by clicking the Restart or Start button.
Linux Thinclient:
(In the following instructions, inside adskscmX
and simulation-computeX
, X
should be replaced with SCM major release)
Issue the command
ps -eaf | grep SimulationCompute
in a terminal. Four processes bearing the name SimulationCompute should be present and running with the following information present in their respective command line:- SimulationCompute (The main process)
- ComputeQueue
- ComputeStorage
- ComputeProvisioner
If ANY of the above is not true, stop any existing Simulation Compute Manager daemon by killing the PID specified in the
--pidfilename
argument used to start the daemon.Allow sufficient time for the processes to exit cleanly.
Make sure the SimulationCompute processes are terminated by calling
/sbin/pidof SimulationCompute
.If a process IDs are returned, kill the all processes using
kill -9 '<process ID>'
.Restart the service by running
$INSTALL_ROOT/opt/Autodesk/simulation-computeX/bin/SimulationCompute
.
- Linux Workstation
Check the status of the service by issuing the command:
systemctl status adskscmX
.If the status is not active (running) restart the service by issuing the command
sudo systemctl restart adskscmX
To open the port in the firewall settings
Example for RedHat/Centos
Issue the command
SCM 1.X versions
firewall-cmd --permanent --add-port=43100/tcp
.SCM 2.0+ versions
firewall-cmd --permanent --add-port=44100/tcp
.Issue the command
firewall-cmd --reload
.
Both of the above commands should return success
.