Description
What's New in Autodesk ObjectARX for AutoCAD 2023.
New in AcDb
Topic |
Description |
---|---|
Not intended to be used by ObjectARX applications because the AcDbObject audit methods expect a system-created AcDbAuditInfo object. | |
Returns the database associated with this instance of an AcDbAuditInfo object. | |
Sets the database associated with this instance of an AcDbAuditInfo object. | |
Defines the symbol iterator type. | |
Checks for a registered application name. | |
Registers an application name (for use by Xdata). | |
Defines the symbol iterator type. | |
Defines the symbol iterator type. | |
Defines the symbol iterator type. | |
Returns the name of the long transaction. For identification purposes, this is normally the name of the origin block. However, if the origin block is an Xref, it returns the name of the Xref Block in the host drawing. If the block is a Layout, it returns the name of the Layout. | |
Defines the symbol iterator type. | |
This static member function creates AcDbRegion objects from the closed loops represented by the curves contained in the curveSegments array.The newly created region objects are returned in the regions array. | |
Defines the symbol iterator type. | |
Defines the symbol iterator type. | |
Calls the getObject() function of the top transaction passing on all the arguments it has received.Note: Template allowing callers to pass in any pointer type and helps to avoid unsafe (AcDbObject * &) casts.Objects can only be obtained within the top transaction, so this function saves the trouble of having to either keep a pointer to the top transaction or use the AcTransactionManager::topTransaction() function to obtain it.The AcDbTransactionManager::getObject() function is the transaction equivalent of acdbOpenObject(). A pointer to the object identified by objectId is obtained under the transaction and returned in the pObject argument. The mode argument specifies how the object is to be treated--as AcDb::kForRead, AcDb::kForWrite, or AcDb::kForNotify. If the openErasedObject Boolean is Adesk::kTrue, then even an erased object can be obtained. If openErasedObject is Adesk::kFalse, then trying to obtain an erased entity results in an error return value.Returns Acad::eOk if successful. If openErasedObject is Adesk::kFalse, then trying to obtain an erased object results in a return status of Acad::eWasErased. If there are currently no transactions, then it returns Acad::eNoActiveTransactions.Reminder: Obtaining an object pointer via getObject() runs in parallel with acdbOpenObject(). This means that both can be in effect at the same time with AcDb::kForWrite status in both. For more information, see the section on transactions in the ObjectARX Developer's Guide. | |
Defines the symbol iterator type. | |
Defines the symbol iterator type. | |
Defines the symbol iterator type. |
New in AcAp
Topic |
Description |
---|---|
Returns a new pointer to an AcApDocumentIterator object. | |
Checks to see if this is a floating frame and the floating frame is pinned. | |
Fired when a document window is to be docked from a floating frame back to the MDI child frame. |
New in AcGi
Topic |
Description |
---|---|
The context can be thought of as the root object of the regeneration. A single instance of an AcGiContext-derived class serves as a point of reference during a given regen. It is accessible via both AcGiWorldDraw and AcGiViewportDraw and hence is always available to the client.It is guaranteed that the AcGiViewportDraw passed in to viewportDraw() will return the same instance of AcGiContext as that returned by the instance of AcGiWorldDraw passed into the preceding call to worldDraw(). | |
Indicates whether the hatch object is forced to fill itself as it is being drawn. | |
Indicates whether the background for hatch objects is suppressed. | |
Indicates whether smart mode is used to control the drawing and indexing of hatch objects with dense patterns; objects are drawn with the pattern or as a solid. |
New in AcGs
Topic |
Description |
---|---|
Gets the value for the advanced Metal mode.Note: This setting is related to the Apple Metal API. | |
Sets the value for the advanced Metal mode.Note: This setting is related to the Apple Metal API. |
New in AcRx
Topic |
Description |
---|---|
Helper template that performs object cloning, casting and error checking. |
New in AcTransaction
Topic |
Description |
---|---|
Transaction equivalent of acdbOpenObject.Note: Template allowing callers to pass in any pointer type and helps to avoid unsafe (AcDbObject * &) casts.A pointer to the object identified by objectId is obtained under the transaction and returned in the obj argument. The mode argument specifies how the object is to be treated--as AcDb::kForRead, AcDb::kForWrite, or AcDb::kForNotify. If the openErasedObject Boolean is true, then even an erased object can be obtained. If openErasedObject is false, then trying to obtain an erased entity results in an error return value.Returns Acad::eOk if successful. If openErasedObject is false, then trying to obtain an erased object results in a return status of Acad::eWasErased. If there are currently no transactions, then it returns Acad::eNoActiveTransactions.Reminder Obtaining an object pointer via getObject() runs in parallel with acdbOpenObject(). This means that both can be in effect at the same time with AcDb::kForWrite status in both. For more information, see the section on transactions in the ObjectARX Developer's Guide.Note This function is duplicated in the AcTransactionManager class where it always operates on the topmost AcTransaction object (by calling the getObject() function in the topmost transaction object). Only the topmost transaction is allowed to obtain entities, so using the AcTransactionManager version of this function is safer and easier. |
New in AcTrayItem
Topic |
Description |
---|---|
Represents the click event's callback data. | |
Represents the function address of the click event's callback. |
New in Global Functions
Topic |
Description |
---|---|
Deprecated. Formats an angle into a string.The value to format should correspond to values allowed for the AutoCAD system variable AUNITS, which are described in acdbAngToF().The current value of the AutoCAD dimensioning variable DIMZIN controls how acdbAngToS() writes leading or trailing zeros to str. See the AutoCAD User's Guide for possible values of DIMZIN.On success returns RTNORM, otherwise returns an error code. | |
Identical to acdbAngToS(), except that the input angle is not reduced to the range (-360,360). | |
Formats a floating-point value as a string.The following table lists the valid values for the units argument.Linear units values: | |
Searches for the specified file.The result argument must point to a buffer large enough to hold the qualified file name: depending on the directory structure of the current environment, this can be quite long. The maximum length of result is platform dependent. On platforms that restrict file-name length, it is 78 characters; on platforms that don't restrict file-name length, it is 511.This function makes no assumption about the type of the file, and does not attempt to append any kind of file-name extension. If the file you are searching for does have an extension to its name, the extension must be included in the fname argument.If fname is qualified by including a drive or directory prefix (for example, "d:test.exp"), acedFindFile() searches only that disk or directory. Otherwise, acedFindFile() searches for fname according to the current AutoCAD library path, which consists of the following directories, in order:
Depending on the current environment, two or more of these directories may be the same.If acedFindFile() finds the file, it returns RTNORM; otherwise, it returns RTERROR. | |
Searches the AutoCAD trusted file paths for the specified file. The command looks for the file in the regular AutoCAD search path. If a match is found, it verifies if the file path is part of trustedpaths. If the file is not present in any of the directories in the trusted file paths, the function returns NULL. | |
Retrieves the localized or English name of an AutoCAD command after allocating memory for it.The acedGetCName() function returns RTNORM to indicate success, RTERROR to indicate failure to allocate memory for the string result, or another error code if the function fails to retrieve the result. | |
Retrieves the value of an environment variable. Looks first in the AutoCAD-specific FixedProfile/General section of the registry: | |
Gets user input for an integer.The AutoCAD user can enter any valid 32-bit integer.The user cannot respond to acedGetInt() by entering an AutoLISP expression.The acedGetInt() function returns one of the following: RTNORM if it succeeds, RTERROR if it fails, or RTCAN if the user cancels the request (by pressing [ESC]). A prior call to acedInitGet() can also enable return values of RTNONE or RTKWORD. | |
Gets user input for an integer.The AutoCAD user can enter any valid 32-bit integer.The user cannot respond to acedGetInt() by entering an AutoLISP expression.The acedGetInt() function returns one of the following: RTNORM if it succeeds, RTERROR if it fails, or RTCAN if the user cancels the request (by pressing [ESC]). A prior call to acedInitGet() can also enable return values of RTNONE or RTKWORD. | |
This function provides access to the Windows Favorites directory of the current user.Note: This overload does not take a size arg and is deprecated. Use the other overload instead.Returns Adesk::kTrue on success; Adesk::kFalse on failure. | |
This function accepts a path to an (MSIE-compatible) Internet shortcut file and extracts the URL from it (the inverse of acedCreateInternetShortcut()).It is the caller's responsibility to ensure that szURL points to a sufficiently large buffer.Returns Adesk::kTrue on success; Adesk::kFalse on failure. | |
This function resolves Windows shell links (in other words, shortcuts and returns the path to the underlying object (the inverse of acedCreateShortcut()).Returns Adesk::kTrue on success; Adesk::kFalse on failure. | |
Define this if you want auto initialization of AcRxClasses in your DLL. | |
Removes a C++ class from the ObjectARX run-time class tree and do all the necessary cleanup that may be involved, such as making a proxy of any objects or entities of the class that are present in any AcDbDatabase objects. pClassObj must point to the AcRxClass object that is in the ObjectARX run-time class tree and represents the C++ class to be removed.Note: For Internal Use Only. |
New in MFC Extension Classes
Topic |
Description |
---|---|
Called to determine the height of each item in the list, in pixels. By default, returns a value calculated from the height of an OR bar (|) using the control's current font. | |
Called to determine the height of each item in the list, in pixels. By default, returns a value calculated from the height of an OR bar (|) using the control's current font. | |
Gets a filesystem type object based on the specified volume. |
New in Miscellaneous Classes
Topic |
Description |
---|---|
Variadic method allows appending an arbitrary list of values.E.g.: arr.appendList(v1, v2, v3); | |
Appends the value to the array n times.E.g.: arr.appendRep(v1, 7); | |
Initializes new cells to value. |
New Types and Unions
Topic |
Description |
---|---|
This typedef defines the color information and dimensions for a device independent bitmap (DIB) file. |