Share
 
 

Functions Reference (AutoLISP)

Listing of AutoLISP functions by alphabetic name and feature.

Alphabetic List

A B C D E F G H I J K L M N O P Q R S T U V W X Y Z

Non-alphabetic

External

Feature List

Basic

Core functions that are used to perform mathematical calculations, manipulate list and strings, provide error handling for programs, and much more.

Application-Handling

Arithmetic

Equality and Conditionals

Error-Handling

Function-Handling

List Manipulation

String-Handling

Symbol-Handling

Utility

Functions that are used to convert between data types, work with standard AutoCAD commands, get input from the user at the command prompt, and much more.

Data Conversion

Device Access

Display Control

File-Handling

Geometric

Query and Command

User Input

Memory Management

Windows Registry and Property List Files

Selection Set, Object, and Symbol Table

Functions used to work with extended data (Xdata), manipulate and select objects, and work with symbol tables and dictionaries.

Extended Data-Handling

Object-Handling

Selection Set Manipulation

Symbol Table and Dictionary-Handling

Programmable Dialog Boxes - DCL

Functions used to display and implement actions for dialog boxes defined in DCL files.

Dialog Box Opening and Closing

Tile- and Attribute-Handling

List Box and Pop-Up List-Handling

Image Tile-Handling

Application-Specific Data-Handling

Tile Attributes Reference

Tiles Reference

ActiveX Library Functions (Windows only)

Functions used to utilize the AutoCAD ActiveX API with AutoLISP.

Note: AutoCAD, not AutoCAD LT, also supports the use of third-party ActiveX APIs.

ActiveX Collection Manipulation

ActiveX Data Conversion

ActiveX Method Invocation

ActiveX Object-Handling

ActiveX Property-Handling

Curve Measurement

Dictionary

Handling Drawing Objects

Reactors

VLX Namespace

Namespace Communication

Express Tools Library Functions (AutoCAD for Windows only)

Functions made available by installing Express Tools and loading the acetutil modules (acetutil.arx and acetutil*.fas).

Entity and Selection Set Functions Reference

File Functions Reference

Initialization File and Registry Functions Reference

String Functions Reference

System Functions Reference

User Interface and Help Functions Reference

Was this information helpful?