Description
What's New in Autodesk ObjectARX for AutoCAD 2024.
New in AcDb
Topic |
Description |
---|---|
This inline method calls the class's readString method (see AcDbDwgFiler::readString for more information). | |
This constructor enables setting of pt and appData members. All other members are set to NULL. | |
Returns an integer that indicates the id is greater than, less than, or equal to the value in *this.
| |
Override the virtual function for the drawing of point cloud. |
New in AcGs
Topic |
Description |
---|---|
Updates the status of the adapter. |
New in Global Functions
Topic |
Description |
---|---|
Used to determine if the tight extents calculations are enabled for AcDb3dSolid, AcDbSurface, and AcDbRegion entities. | |
Used to enable the tight extents calculations before using getGeomExtents on the AcDb3dSolid, AcDbSurface, and AcDbRegion entities. |
New in MFC Extension Classes
Topic |
Description |
---|---|
Enables the use of Windows 11 UI features for the Application frame. | |
Sets the Application Button size for the Application frame. | |
Override of the non-virtual base class method. Registers a tool with the tooltip control.See MFC help for more documentation. | |
Override of the non-virtual base class method. Registers a tool with the tooltip control.See MFC help for more documentation. | |
Override of the non-virtual base class method.Updates the tooltip text for this control's tools. | |
Override of the non-virtual base class method.Updates the tooltip text for this control's tools. | |
Indicates whether the path represents a virtual file/directory. |
New in Miscellaneous Classes
Topic |
Description |
---|---|
Utility class for use with AcArrays. | |
Helper method for arrays of pointers.Deletes all pointers in the array and sets the array to empty.E.g., if arr is an AcArray<SomeType *>, where SomeType is not void, then we can say: AcArrayUtil::deletePtrs(arr); if bFreeBuffer is true, then remove AcArray's allocated buffer.Otherwise mem buffer is retained and re-used if bUseArrayDelete is true, then call delete[] instead of delete.For use with ptrs to C-style arrays, as in arr.append(new T[3]); | |
Helper method for arrays of void ptrs, which need to be deleted as pointers to a specific type. Caller specifies the pointer type.E.g.: AcArray::deleteVoidPtrs<MyType>(arr); // where arr is AcArray<void *>E.g., if arr is an AcArray<void *>, where the pointers actually are to SomeType, then we can say: AcArrayUtil::deleteVoidPtrs<SomeType>(arr);Note:void ptrs are not type safe and should only be used as a last resort. | |
API that allows for the addition of arbitrary properties to drawing extraction results. | |
Initialize this AcString from a std::wstring. | |
Initialize this AcString from a std::wstring_view. | |
Constructs a string and initializes it from a std::wstring. | |
Constructs a string and initializes it from a std::wstring_view. | |
Truncates the string from the given index. | |
Queues an object for property extraction with the BeginExtractionEventArgs::queueForExtraction event. | |
Queues an object for property extraction. The properties extracted are subject to change. | |
Adds an object's property for extraction with the EndExtractionEventArgs::addProperty event. | |
Adds a property to the property database. | |
A singleton who purpose is to act as event source for clients who want to observe the extraction process to add their own properties. | |
Adds a reactor/observer.Reactors must be removed before they are destroyed. | |
Constructor. | |
Removes a reactor/observer.Reactors must be removed before they are destroyed. | |
Returns the singleton instance of the Extractor. | |
Reactor/Observer interface. | |
Called at the beginning of the extraction process.Gives clients an opportunity to queue extra objects for property extraction. | |
Called at the end of the extraction process.Gives clients an opportunity to add extra properties to extraction results. |
New Enum
Topic |
Description |
---|---|
State of the Autodesk Application Frame. |