Issue:
After configuring a FLEXlm® license server with licenses, users of the product were not able to pull a license. In the debug log file, the following errors were displayed:
<timestamp> (adskflex) Invalid license key (inconsistent authentication code)
<timestamp> (adskflex) ==>INCREMENT <ProductFeature> adskflex 1.000 <LicenseType> <LicenseCount> \
Causes:
- License in a combined license file is encrypted on wrong MAC address.
- Combining different release versions of same product package license code in one license file.
- Signature broken.
Solution:
To workaround perform the following steps:
- The server hostname and MAC address (physical address) used to generate this license file are incorrect. You should verify that the server information listed in the license file matches the details on the System Settings tab in LMTOOLS. These errors can also occur if you combine multiple license files and the server hostname and MAC address are not consistent between all license increments.
- The version of FLEXlm® or FLEXnet being used is out of date. Check the Network Licensing Guide for your product to determine the correct FLEXlm version. Check the debug log file to make sure that both Lmgrd and Adskflex display the correct version.
- Generate a new network license file.
Note: The server hostname and MAC address listed at the top of Autodesk license files are encrypted into each product increment and cannot be manually edited without invalidating the license file. If the server information is incorrect or you have manually modified the server details, you will need to submit a new request for a license file from Autodesk.
