Issue:
Users reported that Fusion has performance issues when working in various workspaces.
These performance issues may be seen during any of the following:
- Opening, saving, and exporting files.
- Accessing the Data Panel.
- Orbiting, Panning, Zooming.
- Working in sketches, including creating and managing new or projected geometry.
- Computing features in the timeline.
- Updating components or using the "Get latest" command.
- Creating a Section Analysis.
- Programming, regenerating, or renaming CAM toolpaths.
- Using CAM libraries, such as the Tool, Machine, or Posts library.
- Switching between open tabs or workspaces.
- Minimizing Fusion or switching to another open program window.
- Opening or closing dialogs with command buttons.
- Extruding a body.
Causes:
Slow performance could be caused by any of the following:
- Hardware limitations.
- Network Connectivity issues.
- AntiVirus blocking the software.
- Poor modeling habits in the timeline.
- Graphics drivers not installed/not updated.
- Running other High-GUI based application(s) while working with Fusion.
Solution:
Confirm that the operating system meets the Autodesk Fusion system requirements.
Check if the operating system meets the Autodesk Fusion requirements: System requirements for Autodesk Fusion
Close other applications.
Other High-GUI based applications that consume system resources will slow Fusion down as well. Close unnecessary applications, adjust application priority.
Update, Reset, or Repair Fusion.
- Update Fusion: How to update Fusion
- Clear cache data: How to clear the local user cache in Fusion
- Reset Fusion: Overview of Reset Fusion Command from Fusion Service Utility
- Leave the following deselected: "Keep offline user cache".
- Repair Fusion: Overview of Repair Fusion Command from Fusion Service Utility
Check the graphics card drivers.
- Update the drivers to the latest version. See: How to update graphics driver for Fusion in Windows
- Perform a clean-re-installation of the graphics driver (the procedure will vary depending on the manufacturer of the GPU).
- If a dual graphics system is being used, make sure that the correct discrete graphics card is in use. For further information, see: "Your graphics card might not be optimal to run Fusion" or crashing when launching Fusion
- How to configure Autodesk software to use high-performance graphics
Adjust preferences for better performance.
- Optimize Fusion for performance by setting the Graphics Preset to Performance, see: How to limit effects to optimize performance in Fusion
- Go to the preferences > Go to Data Collection and Use > Disable any analytics.
- Go to the preferences > Go to General > Select the graphics driver option > Test between the available options (DirectX 9, DirectX 11, OpenGL).
Deactivate / Update add-ins.
- If there are any add-ins installed, deactivate or update them, and restart Fusion.
- See: How to disable the automatic launch of a Fusion App/Add-ins
Adjust all visual effects for the best performance (Windows).
- Open Performance Information and Tools by opening the Control Panel.
- In the search box, type Performance Information and Tools.
- In the list of results, click Performance Information and Tools.
- Click Adjust visual effects. Administrator permission is required. If prompted for an administrator password or confirmation, type the password or provide confirmation.
- Click the Visual Effects tab.
- Click Adjust for best performance.
- Click OK. (For a less drastic option, select Let Windows choose what’s best for my computer).
Check Power options on (Windows).
Check the power options in both the control panel, and settings to verify that there isn't a low-power, energy-saving, or eco mode turned on.
- Check the power mode in the control panel first (if the eco mode is selected here it can limit the power options shown in the 'Settings' menu). See: Change the power mode for your Windows PC
- Check the power and sleep settings through the steps here: How to adjust power and sleep settings in Windows
Antivirus and network connectivity issues.
- Configure antivirus to allow Fusion to work properly by following this article: Configuring anti virus software for use with Fusion
- Note: For McAfee, make sure that Fusion is removed from the Netgear feature.
- Address any network connectivity issues using the article: Troubleshooting Network Connectivity Issues for Autodesk Fusion
Use Mac Disk Utility.
Use the Disk Utility to First Aid to improve performance on your Mac.
Manual uninstall and reinstall Fusion.
Perform a manual clean uninstall of Autodesk Fusion and then reinstall by downloading Fusion from your Autodesk Account.
See Also:
- Poor performance when working with large files in Fusion
- Performance is poor when inserting or importing a DXF, DWG, or SVG file into Fusion
- Debugging Your Fusion Design: Let's Get Rid of Red and Yellow Features
- How to configure Autodesk software to use high-performance graphics
- Slow performance after inserting or converting a mesh in Fusion