Issue:
When launching the software, the following error message may appear:
A valid license could not be obtained by the network license manager. Try again. If you are still unable to access a license, contact your system administrator.
Error [1.5.-18]
Causes:
- Out-of-date version of the Autodesk Network License Manager (FlexLM).
- Permissions to client side licensing components.
- Masking another error message.
- PLIST information missing from the license file (AutoCAD 2007 and newer versions).
- Missing/broken client side licensing components (AutoCAD 2007 and newer versions).
Solution:
See below solutions. Test the software after performing each:
Out-of-date version of the Autodesk Network License Manager (FlexLM)
AutoCAD 2006 and newer versions require a minimum of version 10.1.5 of the Autodesk Network License Manager (FlexLM) to support advanced licensing information. Check the debug log file to confirm the version of the license manager core components (lmgrd and adskflex). Refer to the following solution to upgrade the Autodesk Network License Manager: Upgrading Autodesk Network License Manager (FLEXlm®).
Permissions to client side licensing components
The user attempting to start the software must have the appropriate permissions to operating system locations in order to locate and interpret information from the license manager. Make sure that the user currently logged in has at least read access to:
- C:\Program Files\AutoCAD 2008\Licpath.lic.
Path will vary depending on the product installed.
- HKEY_LOCAL_MACHINE\Software\FlexLM License Manager.
- C:\Documents and Settings\All Users\Application Data\Autodesk\NetService.
AutoCAD 2007 and newer versions.
Masking another error message
The 1.5.-18 error often masks another, more relevant network licensing error that can be easily diagnosed. Check that the desired license server is running and has licenses available for the specific product. Make sure that a license can be pulled from the same license manager for this product and version from another client workstation.
PLIST information missing from the license file (AutoCAD 2007 and newer versions)
The 1.5.-18 error can often indicate missing or corrupted PLIST information in the license file. Make sure that all PLIST increments for all Autodesk product license files exist in the currently active license file. Check the Server Status and debug log file to ensure that the PLIST increment is available and no errors are reported with the PLIST. Refer to the following solution for instructions and examples of combined Autodesk license files: Combining Autodesk® license files.
Missing/broken client side licensing components (AutoCAD 2007 and newer versions)
Licensing components on the client workstation tell the software how to download and interpret PLIST and other licensing information. If these components are missing or not working correctly, it can lead to a failure of the product to pull the correct license from the license manager or a failure of license cascading. Check the following:
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Check the Windows Control Panel > Administrative Tools > Services for the Autodesk Network Licensing Service. Verify that the service can be started and stopped without any error. Note that this service should be left in a stopped state with Manual startup.
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Check the C:\Documents and Settings\All Users\Application Data\Autodesk\NetService directory and verify that the AdskNetSrv.DAT file exists.
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If it does exist, delete it, and then restart the software to force the download of the latest PLIST data from the license file.
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If it does not exist, check the PLIST increment in the license file and verify that it is available. Verify that the license is being pulled from the correct license manager. Refer to the following solution to set the ADSKFLEX_LICENSE_FILE environment variable to point the client machine at the correct license manager: Specifying license servers using the ADSKFLEX_LICENSE_FILE environment variable.
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