Issue:
The following message may appear when trying to install Fusion:
Problem installing Fusion
What's wrong? |
We are not sure what is preventing installation. |
What should I do? |
Check if you are experiencing any of these known issues and follow the given recommendation. If Fusion 360 still does not install, collect the log files and contact us through Fusion 360 Support Forum for help. |
Causes:
Installation log files may help with understanding the error messages and their causes.Find the installation logs at the following location:
- Windows - C:\Users\***\Appdata\Local\Autodesk\autodesk.webdeploy.streamer.log
- macOS - Macintosh HD>Users>***>Library>Logs>autodesk.webdeploy.streamer.log
Search for the following in the installation log files and refer to the following for the corresponding solution:
- Errno.
- SSL.
- Socket.
- Connection.
- Gaierror.
- Getaddrinfo.
- Timeout.
Solution:
First, try this troubleshooter form to solve the most common issues causing issues installing Fusion.
Then attempt the following:
Repair Fusion
Repair Fusion using the Service Utility, refer to: Overview of Repair Fusion Command from Fusion Service Utility.
[Errno 13] Permission denied
- Make sure to have full read/write privileges to the installation directories.
- Create an admin profile on the same computer and install Fusion on it. If the installation is successful, there might be permission limitations on the original profile.
- Try resetting the computer. In macOS, it is important to distinguish between restart and reset. A restart may not completely clear the issue. Shutting off the computer and then back on should reset the full computer.
- Antivirus security software can sometimes block the Fusion install. Check this by disabling any antivirus and trying again. The antivirus can be turned back on once the installation is complete.
[Errno 22] Invalid argument
- Restart the computer.
- Close any Autodesk Account desktop applications.
- Open File Explorer.
- Navigate to %localappdata%/Autodesk.
- Delete/rename the Webdeploy and Web services folders.
- Reinstall Fusion.
SSL
Quit the installer and run it again.
Socket
- Quit the installer and run it again.
- Antivirus software or firewall might be blocking the installation. Check the antivirus software to understand why the Fusion installation was blocked. The security settings may need to be modified or temporarily disabled to install Fusion.
- Reset Internet Options.
Connection
- Quit the installer and run it again.
- Modify proxy server settings.
- Antivirus software or firewall might be blocking the installation. Check the antivirus software to understand why the Fusion installation was blocked. The security settings may need to be modified or temporarily disabled to install Fusion.
- Use an Ethernet cable instead of a Wi-Fi connection as per: "Problem installing Fusion 360. SSL: DECRYPTION_FAILED_OR_BAD_RECORD_MAC" when installing Fusion.
Gaierror
Add exceptions for Fusion to the firewall and antivirus software or disable the antivirus software. Refer to:
- How to set up antivirus (AV) exclusions to improve stability and performance of Autodesk software.
- Which URLs/Protocols need to be allowed for Autodesk Subscription Licensing.
- Autodesk Licensing Service: Known Conflicting Applications.
Getaddrinfo
Add exceptions for Fusion to the firewall and antivirus software or disable the anti-virus software. Refer to:
- How to set up antivirus (AV) exclusions to improve stability and performance of Autodesk software.
- Which URLs/Protocols need to be allowed for Autodesk Subscription Licensing.
- Autodesk Licensing Service: Known Conflicting Applications.
Timeout
- Perform a Network Reset.
- Make sure that all ports and domains are not being blocked.
Old Installer used
- The new Fusion installer does not contain the "360" in the name and has an orange icon.
- Download the latest version of Fusion from the Autodesk Account to install it.
See Also:
- "Unable to install" when installing Fusion
- "No Internet connection" when installing Fusion
- "Server problem" when installing Fusion
- "Leftover files" when installing Fusion
- "Missing files" when installing Fusion
- "Permissions problem" when installing Fusion
- "PermissionError: [Errno 13] Permission denied" when updating or installing Fusion
- "Multiple installers" when installing Fusion
- "Disk full" when installing Fusion
- "Latest Version already installed" when installing Fusion
- "Problem installing Fusion 360. [Errno 13] Permission denied" when installing Fusion
- "Problem installing Fusion 360 [Errno 22] Invalid Argument" when installing Fusion
- "Problem installing Fusion 360. Nested asn1 error (_ssl.c:4003)" when installing Fusion
- Using installation log files to resolve installation or update problems in Fusion
- "CorruptError: database disk image is malformed" when attempting to install or update Fusion 360