Issue:
Users reported that the following warning appears when starting or using Fusion:
Server Verification Warning Unable to validate a security certificate. Many times this can be triggered by proxy servers, security software, or out of date OS patches. Please visit the "Network/Server Verification" preference page if you would like to change this setting.
Causes:
There are a number of causes for this warning, including:
- The local system time is incorrect.
- The server time is incorrect.
- Decrypting proxy server time is incorrect.
- The server or proxy server certificate is invalid, expired, or revoked.
- The revocation server listed in the certificate is unreachable (not found by DNS, blocked by the network, offline).
- The certificate's parent is not found in the certificate store used or the operating system's trusted root certificate store.
- Expired trusted root certificates in the certificate store or the operating system's trusted root certificate store.
- There is no Proxy server setup.
- Internal network issue.
Solution:
What does this error mean?
A network configuration error is causing secured communication problems with the services. This could indicate a security risk (the connection could be vulnerable to a man in the middle attack) or a network settings problem.
What actions are available and what do they mean?
- Trust Anyway - will ignore this and any future errors during this session.
- Work Offline - will transition Fusion to work in offline mode.
- Cancel - will continue with the failure. The current operation will fail, but the session will continue as is. The error may reoccur unless you change the network setting to resolve the issue.
Why the notification is displayed?
The Server Verification settings in the Network preferences in Fusion are set to "Warn when accessing through an intermediate server."
To disable the warning perform the following steps:
- Go to the Preferences menu.
- Go to the Network section of the Preferences dialog.
- Change the Server Verification settings to
- "Do not warn when accessing through an intermediate server": This setting will always trust the network and connect when a risk is detected.
- "Block access when an intermediate server is detected": This setting will always stay secure and block network connection when a risk is detected.
Recommended diagnostics:
- Review the application log files for network error, see How to manually collect the log files for Autodesk Fusion.
- Go to the following folder: Autodesk Fusion 360\(Alphanumeric Folder)\logs
- Search the application log files for network connection errors:
- "404 (missing)" or "401 (unauthorized)": These errors or warnings are not related to this issue.
- "failure to resolve host": This could indicate a DNS problem (Restart your modem/router).
- "TLS": These errors could point to an issue with the TLS (SSL) handshake or certificates. Example:
20220121T140745 E 5568 DOWNLOAD 35 https://cdn.us.oss.api.autodesk.com/oss/v2/signedresources/... schannel: next InitializeSecurityContext failed: SEC_E_ILLEGAL_MESSAGE (0x80090326) - This error usually occurs when a fatal SSL/TLS alert is received (e.g. handshake failed). More detail may be available in the Windows System event log.
- Accessing the scheme and host part of the URL from the error in the application log (for example here, excluding the path) in a browser like Chrome, Firefox or Safari may reveal more about the nature of the connection issue.
- More advanced network diagnostic tools like Fiddler or Charles (Mac) that monitor the network traffic can provide further insight. Recommended step for IT professionals.
Note: The local IT administrator can use information from the recommended diagnostics steps to determine the cause of the failure for a given network configuration.
Extra Solutions:
- Verify that the operating system's and/or server's time and date match the local Internet time. See this article for more information: "Time mismatch with server" message when launching Fusion.
- Install pending updates for your operating system. For Windows or macOS.
- Reinstall Fusion by running the Repair Fusion Command from Fusion Service Utility.