Specifies the distance a 2D AutoCAD object is extruded above or below its elevation.
Supported platforms: Windows only
VBA:
object.Thickness
Read-only: No
Type: Double
The default is 0.0.
Changing the thickness of an object changes its Z direction thickness.
Changing the thickness of a 3D polyline, dimension, or floating viewport has no effect.
VBA:
Sub Example_Thickness() ' This example creates a circle in model space ' and changes the thickness of the circle. Dim circleObj As AcadCircle Dim centerPoint(0 To 2) As Double Dim radius As Double ' Define the circle centerPoint(0) = 0#: centerPoint(1) = 0#: centerPoint(2) = 0# radius = 5# ' Create the Circle object in model space Set circleObj = ThisDrawing.ModelSpace.AddCircle(centerPoint, radius) ZoomAll ' Find the current thickness of the circle Dim currThickness As Double currThickness = circleObj.Thickness MsgBox "The thickness of the circle is " & circleObj.Thickness, vbInformation, "Thickness Example" ' Change the thickness of the circle circleObj.Thickness = currThickness + 3 circleObj.Update ' Change the direction of the viewport so that you can ' view the change made to the thickness. Once you change ' the direction, you must reset the active viewport. Dim NewDirection(0 To 2) As Double NewDirection(0) = -1: NewDirection(1) = -1: NewDirection(2) = 1 ThisDrawing.ActiveViewport.direction = NewDirection ThisDrawing.ActiveViewport = ThisDrawing.ActiveViewport MsgBox "The thickness of the circle is now " & circleObj.Thickness, vbInformation, "Thickness Example" End Sub
Visual LISP:
(vl-load-com) (defun c:Example_Thickness() ;; This example creates a circle in model space ;; and changes the thickness of the circle. (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) ;; Define the circle (setq centerPoint (vlax-3d-point 0 0 0) radius 5) ;; Create the Circle object in model space (setq modelSpace (vla-get-ModelSpace doc)) (setq circleObj (vla-AddCircle modelSpace centerPoint radius)) (vla-ZoomAll acadObj) ;; Find the current thickness of the circle (setq currThickness (vla-get-Thickness circleObj)) (alert (strcat "The thickness of the circle is " (rtos currThickness 2))) ;; Change the thickness of the circle (vla-put-Thickness circleObj (+ currThickness 3)) (vla-Update circleObj) ;; Change the direction of the viewport so that you can ;; view the change made to the thickness. Once you change ;; the direction, you must reset the active viewport. (setq NewDirection (vlax-3d-point -1 -1 1)) (setq activeViewport (vla-get-ActiveViewport doc)) (vla-put-Direction activeViewport NewDirection) (vla-put-ActiveViewport doc activeViewport) (vla-ZoomAll acadObj) (alert (strcat "The thickness of the circle is now " (rtos (vla-get-Thickness circleObj) 2))) )