Point Object (ActiveX)

A point marker appearing as a dot, square, circle, X, tick, or plus sign (+); or as a combination of these.

Supported Platforms: Windows only

Class Information

Class Name

AcadPoint

Object Inheritance
Object
   AcadObject
      AcadEntity
         AcadPoint
Create Using

VBA

ModelSpace.AddPoint
PaperSpace.AddPoint
Block.AddPoint
Access Via

VBA

ModelSpace.Item
PaperSpace.Item
Block.Item
SelectionSet.Item
Group.Item

Members

These members are part of this object:

Remarks

You can specify a full 3D location for a point. The current elevation is assumed if you omit the Z coordinate.

Points can act as nodes to which you can snap objects. Also, the Coordinates property provides an array that can be used in any method requiring a point as an input parameter.

Controlling the Appearance of Points

The PDMODE and PDSIZE system variables control the appearance of point objects. PDMODE values 0, 2, 3, and 4 specify a figure to draw through the point. A value of 1 selects nothing to be displayed.



Adding 32, 64, or 96 to the values above selects a shape to draw around the point in addition to the figure drawn through it:







PDSIZE controls the size of the point figures, except for PDMODE values 0 and 1. A 0 setting generates the point at 5 percent of the graphics area height. A positive PDSIZE value specifies an absolute size for the point figures. A negative value is interpreted as a percentage of the viewport size. The size of all points is recalculated when the drawing is regenerated.

After you change PDMODE and PDSIZE, the appearance of existing points changes the next time AutoCAD regenerates the drawing.

Creating Points

To create a point, use the AddPoint method.