Specifies the height for the dimension or tolerance text.
Supported platforms: Windows only
VBA:
object.TextHeight
Type: Dim3PointAngular, DimAligned, DimAngular, DimArcLength, DimDiametric, Dimension, DimOrdinate, DimRadial, DimRadialLarge, DimRotated, MLeader, MLeaderStyle, Tolerance
The objects this property applies to.
Read-only: No
Type: Double
The height for the dimension text.
The initial value for this property is 0.1800.
If the current text style has a fixed text height, this property is ignored.
VBA:
Sub Example_TextHeight() ' This example creates an aligned dimension in model space and ' uses the TextHeight property to increase the height of the ' dimension text Dim dimObj As AcadDimAligned Dim point1(0 To 2) As Double, point2(0 To 2) As Double Dim location(0 To 2) As Double ' Define the dimension point1(0) = 5: point1(1) = 5: point1(2) = 0 point2(0) = 5.5: point2(1) = 5: point2(2) = 0 location(0) = 5: location(1) = 7: location(2) = 0 ' Create an aligned dimension object in model space Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location) ThisDrawing.Application.ZoomAll ' Read and display current dimension text height MsgBox "The dimension text height for this object is currently set to: " & dimObj.textHeight ' Increase the distance of the dimension gap dimObj.TextHeight = 1 ThisDrawing.Regen acAllViewports ' Read and display current dimension text height MsgBox "The dimension text height for this object is now set to: " & dimObj.textHeight End Sub
Visual LISP:
(vl-load-com) (defun c:Example_TextHeight() ;; This example creates an aligned dimension in model space and ;; uses the TextHeight property to increase the height of the ;; dimension text (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) ;; Define the dimension (setq point1 (vlax-3d-point 5 5 0) point2 (vlax-3d-point 5.5 5 0) location (vlax-3d-point 5 7 0)) ;; Create an aligned dimension object in model space (setq modelSpace (vla-get-ModelSpace doc)) (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location)) (vla-ZoomAll acadObj) ;; Read and display current dimension text height (alert (strcat "The dimension text height for this object is currently set to: " (rtos (vla-get-TextHeight dimObj) 2))) ;; Increase the distance of the dimension gap (vla-put-TextHeight dimObj 1) (vla-Regen doc acAllViewports) ;; Read and display current dimension text height (alert (strcat "The dimension text height for this object is now set to: " (rtos (vla-get-TextHeight dimObj) 2))) )