DimOrdinate Object (ActiveX)

A dimension measuring the absolute X or Y position of a point from the origin.

Supported Platforms: Windows only

Class Information

Class Name

AcadDimOrdinate

Object Inheritance
Object
   AcadObject
      AcadEntity
         AcadDimension
            AcadDimOrdinate
Create Using

VBA

ModelSpace.AddDimOrdinate
PaperSpace.AddDimOrdinate
Block.AddDimOrdinate
Access Via

VBA

ModelSpace.Item
PaperSpace.Item
Block.Item
SelectionSet.Item
Group.Item

Members

These members are part of this object:

Methods

Properties

Events

ArrayPolar

ArrayRectangular

Copy

Delete

GetBoundingBox

GetExtensionDictionary

GetXData

Highlight

IntersectWith

Mirror

Mirror3D

Move

Rotate

Rotate3D

ScaleEntity

SetXData

TransformBy

Update

AltRoundDistance

AltSubUnitsFactor

AltSubUnitsSuffix

AltSuppressLeadingZeros

AltSuppressTrailingZeros

AltSuppressZeroFeet

AltSuppressZeroInches

AltTextPrefix

AltTextSuffix

AltTolerancePrecision

AltToleranceSuppressLeadingZeros

AltToleranceSuppressTrailingZeros

AltToleranceSuppressZeroFeet

AltToleranceSuppressZeroInches

AltUnits

AltUnitsFormat

AltUnitsPrecision

AltUnitsScale

Application

ArrowheadSize

DecimalSeparator

DimTxtDirection

Document

EntityTransparency

ExtensionLineColor

ExtensionLineOffset

ExtensionLineWeight

ExtLineFixedLen

ExtLineFixedLenSuppress

FractionFormat

Handle

HasExtensionDictionary

Hyperlinks

Layer

LinearScaleFactor

Linetype

LinetypeScale

Lineweight

Material

Measurement

Normal

ObjectID

ObjectName

OwnerID

PlotStyleName

PrimaryUnitsPrecision

Rotation

RoundDistance

ScaleFactor

StyleName

SubUnitsFactor

SubUnitsSuffix

SuppressLeadingZeros

SuppressTrailingZeros

SuppressZeroFeet

SuppressZeroInches

TextColor

TextFill

TextFillColor

TextGap

TextHeight

TextMovement

TextOverride

TextPosition

TextPrefix

TextRotation

TextStyle

TextSuffix

ToleranceDisplay

ToleranceHeightScale

ToleranceJustification

ToleranceLowerLimit

TolerancePrecision

ToleranceSuppressLeadingZeros

ToleranceSuppressTrailingZeros

ToleranceSuppressZeroFeet

ToleranceSuppressZeroInches

ToleranceUpperLimit

TrueColor

UnitsFormat

VerticalTextPosition

Visible

Modified

Remarks

Ordinate dimensions display the X or Y UCS coordinate of an object along with a simple leader line. The absolute value of the coordinate is used according to the prevailing standards for ordinate dimensions.



An ordinate dimension measuring the absolute X position of a point tangent to a circle

To change the extension lines of an ordinate dimension, change the Rotation and/or TextPosition properties. The extension lines will be recalculated to fit the new requirements.

To create an ordinate dimension, use the AddDimOrdinate method.