AltUnitsScale Property (ActiveX)

Specifies the scale factor for alternate units.

Supported platforms: Windows only

Signature

VBA:

object.AltUnitsScale
object

Type: DimAligned, DimArcLength, DimDiametric, DimOrdinate, DimRadial, DimRadialLarge, DimRotated

The objects this property applies to.

Property Value

Read-only: No

Type: Double

The scale factor that is applied to alternate units.

Remarks

If the AltUnits property is turned on, this property multiplies linear dimensions by a factor to produce a value in an alternate system of measurement. The initial value represents the number of millimeters in an inch.

Initial value of the property is 25.4000.

Note: This property overrides the value of the DIMALTF system variable for the given dimension.

Examples

VBA:

Sub Example_AltUnitsScale()
    ' This example creates an aligned dimension in model space and
    ' uses AltUnitsScale to cycle through some common scales
    ' for the alternate dimension

    Dim dimObj As AcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    
    ' Define the dimension
    point1(0) = 0: point1(1) = 5: point1(2) = 0
    point2(0) = 5: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0
    
    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    ThisDrawing.Application.ZoomAll
    
    ' Enable display of alternate units
    dimObj.AltUnits = True
      
    ' Cycle through some common dimension scales
    
    dimObj.AltUnitsScale = 1         ' Change scale to Inches
    ThisDrawing.Regen acAllViewports
    MsgBox "The alternate dimension units are now set to inches"
    
    dimObj.AltUnitsScale = 25.4     ' Change scale to Millimeters (default)
    ThisDrawing.Regen acAllViewports
    MsgBox "The alternate dimension units are now set to millimeters"
    
    dimObj.AltUnitsScale = 2.54      ' Change scale to Centimeters
    ThisDrawing.Regen acAllViewports
    MsgBox "The alternate dimension units are now set to centimeters"

End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_AltUnitsScale()
    ;; This example creates an aligned dimension in model space and
    ;; uses AltUnitsScale to cycle through some common scales
    ;; for the alternate dimension
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    ;; Define the dimension
    (setq point1 (vlax-3d-point 0 5 0)
          point2 (vlax-3d-point 5 5 0)
          location (vlax-3d-point 5 7 0))

    ;; Create an aligned dimension object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location))
    (vla-ZoomAll acadObj)
    
    ;; Enable display of alternate units
    (vla-put-AltUnits dimObj :vlax-true)
      
    ;; Cycle through some common dimension scales
    (vla-put-AltUnitsScale dimObj 1)         ;; Change scale to Inches
    (vla-Regen doc acAllViewports)
    (alert "The alternate dimension units are now set to inches.")
    
    (vla-put-AltUnitsScale dimObj 25.4)     ;; Change scale to Millimeters (default)
    (vla-Regen doc acAllViewports)
    (alert "The alternate dimension units are now set to millimeters.")
    
    (vla-put-AltUnitsScale dimObj 2.54)      ;; Change scale to Centimeters
    (vla-Regen doc acAllViewports)
    (alert "The alternate dimension units are now set to centimeters.")
)