ToolbarItem Object (ActiveX)

A single button item on an AutoCAD toolbar.

Supported Platforms: Windows only

Class Information

Class Name

AcadToolbarItem

Object Inheritance
Object
   AcadToolbarItem
Create Using

VBA

Toolbar.AddToolbarButton
Toolbar.AddSeparator
Access Via

VBA

Toolbar.Item

Members

These members are part of this object:

Remarks

A toolbar item represents a single button or separator on a toolbar. Toolbar buttons can contain a macro to be executed when they are selected by the user, or they can contain a nested toolbar called a flyout. Separators cannot contain macros or flyouts.

To add or change the macro associated with a toolbar button, use the Macro property. To create a flyout toolbar button, first set the Flyout property to acToolbarFlyout. Then use the AttachToolbarToFlyout method to attach an existing Toolbar object to the button.

You can change the bitmap associated with a button by using the SetBitmaps method. This method allows you to set both the large and small button bitmaps.