CommandDisplayName Property (ActiveX)

Specifies the displayed command name for a button on the toolbar.

Supported platforms: Windows only

Signature

VBA:

object.CommandDisplayName
object

Type: ToolbarItem

The object this property applies to.

Property Value

Read-only: No

Type: String

The string for the command name.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_CommandDisplayName()
    Dim currMenuGroup As AcadMenuGroup
    Set currMenuGroup = ThisDrawing.Application.MenuGroups.Item(0)

    Dim newToolBar As AcadToolbar
    Set newToolBar = currMenuGroup.Toolbars.Add("TestNewToolbar")

    ' Add a button to the new toolbar.
    Dim newButton1 As IAcadToolbarItem
    Dim openMacro As String

    ' Assign the macro string the VB equivalent of "ESC ESC _open "
    openMacro = Chr(3) & Chr(3) & Chr(95) & "open" & Chr(32)

    Set newButton1 = newToolBar.AddToolbarButton("", "NewButton1", "Open a file.", openMacro)

    ' Display the toolbar
    newToolBar.Visible = True

    newButton1.CommandDisplayName = "Open a File"

    ' Read the current value of the Help string
    MsgBox "The current CommandDisplayName for the toolbar button is: " & newButton1.CommandDisplayName

    ' Change the value of the CommandDisplayName
    newButton1.CommandDisplayName = "Open File"

    ' Read the new value of the CommandDisplayName
    MsgBox "The new CommandDisplayName for the toolbar button is: " & newButton1.CommandDisplayName
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_CommandDisplayName()
    (setq acadObj (vlax-get-acad-object))
    (setq currMenuGroup (vla-Item (vla-get-MenuGroups acadObj) 0))

    ;; Create the new toolbar
    (setq newToolBar (vla-Add (vla-get-Toolbars currMenuGroup) "TestToolbar"))

    ;; Assign the macro string the VB equivalent of "ESC ESC _open "
    (setq openMacro (strcat (Chr 3) (Chr 3) (Chr 95) "open" (Chr 32)))
    (setq newButton1 (vla-AddToolbarButton newToolBar "" "NewButton1" "Open a file." openMacro))

    ;; Display the toolbar
    (vla-put-Visible newToolBar :vlax-true)

    (vla-put-CommandDisplayName newButton1 "Open a File")

    ;; Read the current value of the Help string
    (alert (strcat "The current CommandDisplayName for the toolbar button is: " (vla-get-CommandDisplayName newButton1)))

    ;; Change the value of the CommandDisplayName
    (vla-put-CommandDisplayName newButton1 "Open File")

    ;; Read the new value of the CommandDisplayName
    (alert (strcat "The new CommandDisplayName for the toolbar button is: " (vla-get-CommandDisplayName newButton1)))
)