ActiveSelectionSet Property (ActiveX)

Gets the active selection set for the drawing.

Supported platforms: Windows only

Signature

VBA:

object.ActiveSelectionSet
object

Type: Document

The object this property applies to.

Property Value

Read-only: Yes

Type: SelectionSet

The active selection set for the drawing.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_ActiveSelectionSet()
    Dim sset As AcadSelectionSet
    ' The following example returns current selection set from current drawing
    Set sset = ThisDrawing.ActiveSelectionSet
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ActiveSelectionSet()
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
  
    ;; The following example returns the current selection set from the current drawing
    (setq sset (vla-get-ActiveSelectionSet doc))
)