Specifies the degree of the spline's polynomial representation.
Supported platforms: Windows only
Read-only: No
Type: Integer
An integer between 1 and 25 inclusive.
The order of the spline is equal to the degree of the spline plus one (+1).
VBA:
Sub Example_Degree() ' This example creates a spline and returns the degree ' of the spline's polynomial representation. Dim splineObj As AcadSpline Dim startTan(0 To 2) As Double Dim endTan(0 To 2) As Double Dim fitPoints(0 To 8) As Double startTan(0) = 0.5: startTan(1) = 0.5: startTan(2) = 0 endTan(0) = 0.5: endTan(1) = 0.5: endTan(2) = 0 fitPoints(0) = 0: fitPoints(1) = 0: fitPoints(2) = 0 fitPoints(3) = 5: fitPoints(4) = 5: fitPoints(5) = 0 fitPoints(6) = 10: fitPoints(7) = 0: fitPoints(8) = 0 Set splineObj = ThisDrawing.ModelSpace.AddSpline(fitPoints, startTan, endTan) ThisDrawing.Regen True MsgBox "The degree of this Spline's polynomial representation is: " & splineObj.Degree, vbInformation End Sub
Visual LISP:
(vl-load-com) (defun c:Example_Degree() ;; This example creates a spline and returns the degree ;; of the spline's polynomial representation. (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) ;; Define the spline (setq startTan (vlax-3d-point 0.5 0.5 0) endTan (vlax-3d-point 0.5 0.5 0) fitPoints (vlax-make-safearray vlax-vbDouble '(0 . 8))) (vlax-safearray-fill fitPoints '(0 0 0 5 5 0 10 0 0 ) ) (setq modelSpace (vla-get-ModelSpace doc)) (setq splineObj (vla-AddSpline modelSpace fitPoints startTan endTan)) (vla-ZoomExtents acadObj) (vla-Regen doc :vlax-true) (alert (strcat "The degree of this Spline's polynomial representation is: " (itoa (vla-get-Degree splineObj)))) )