Spline Object (ActiveX)

A quadratic or cubic NURBS (nonuniform rational B-spline) curve.

Supported Platforms: Windows only

Class Information

Class Name

AcadSpline

Object Inheritance
Object
   AcadObject
      AcadEntity
         AcadSpline
Create Using

VBA

ModelSpace.AddSpline
PaperSpace.AddSpline
Block.AddSpline
Access Via

VBA

ModelSpace.Item
PaperSpace.Item
Block.Item
SelectionSet.Item
Group.Item

Members

These members are part of this object:

Remarks

A spline is a smooth curve passing through a given set of points. AutoCAD uses a particular type of spline known as a nonuniform rational B-spline (NURBS) curve. A NURBS curve produces a smooth curve between control points. Splines are useful for creating irregular-shaped curves, for example, drawing contour lines for geographic information system (GIS) applications or automobile design.

You create splines by specifying coordinate points. You can close the spline so the start point and endpoint are coincident and tangent. You can also change the spline-fitting tolerance. Fit tolerance refers to how closely the spline fits the set of fit points you specify. The lower the tolerance, the more closely the spline fits the points. At zero tolerance, the spline passes through the points.

To create a spline, use the AddSpline method.