Specifies the suppression of a zero inch measurement in dimension values.
Supported platforms: Windows only
VBA:
object.SuppressZeroInches
Type: DimAligned, DimArcLength, DimDiametric, DimOrdinate, DimRadial, DimRadialLarge, DimRotated
The objects this property applies to.
Read-only: No
Type: Boolean
The initial value for this property is False.
VBA:
Sub Example_SuppressZeroInches() ' This example creates an aligned dimension in model space and ' uses SuppressZeroInches to suppress or view the display of ' zero inches in the dimension display Dim dimObj As AcadDimAligned Dim point1(0 To 2) As Double, point2(0 To 2) As Double Dim location(0 To 2) As Double ' Define the dimension point1(0) = 0: point1(1) = 5: point1(2) = 0 point2(0) = 12: point2(1) = 5: point2(2) = 0 location(0) = 5: location(1) = 7: location(2) = 0 ' Create an aligned dimension object in model space Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location) ' Set the dimension display to a style that works with SuppressZeroInches dimObj.UnitsFormat = acDimLArchitectural ThisDrawing.Application.ZoomAll Toggle: Select Case MsgBox("Press OK to suppress or view the display of zero inches in the dimension", vbOKCancel) Case vbOK ' Toggle the display of zero inches for the dimension value dimObj.SuppressZeroInches = Not (dimObj.SuppressZeroInches) ThisDrawing.Regen acAllViewports Case vbCancel Exit Sub End Select GoTo Toggle End Sub
Visual LISP:
(vl-load-com) (defun c:Example_SuppressZeroInches() ;; This example creates an aligned dimension in model space and ;; uses SuppressZeroInches to suppress or view the display of ;; zero inches in the dimension display (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) ;; Define the dimension (setq point1 (vlax-3d-point 0 5 0) point2 (vlax-3d-point 12 5 0) location (vlax-3d-point 5 7 0)) ;; Create an aligned dimension object in model space (setq modelSpace (vla-get-ModelSpace doc)) (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location)) (vla-ZoomAll acadObj) ;; Set the dimension display to a style that works with SuppressZeroInches (vla-put-UnitsFormat dimObj acDimLArchitectural) ;; Toggle the display of zero inches for the dimension value (vla-put-SuppressZeroInches dimObj (if (= (vla-get-SuppressZeroInches dimObj) :vlax-true) :vlax-false :vlax-true)) (vla-Regen doc acAllViewports) (alert "Suppression of zero inches toggled.") ;; Toggle the display of zero inches for the dimension value back to previous state (vla-put-SuppressZeroInches dimObj (if (= (vla-get-SuppressZeroInches dimObj) :vlax-true) :vlax-false :vlax-true)) (vla-Regen doc acAllViewports) (alert "Suppression of zero inches toggled back.") )