SuppressTrailingZeros Property (ActiveX)

Specifies the suppression of trailing zeros in dimension values.

Supported platforms: Windows only

Signature

VBA:

object.SuppressTrailingZeros
object

Type: Dim3PointAngular, DimAligned, DimAngular, DimArcLength, DimDiametric, Dimension, DimOrdinate, DimRadial, DimRadialLarge, DimRotated

The objects this property applies to.

Property Value

Read-only: No

Type: Boolean

Remarks

The initial value for this property is False.

Note: This value overrides the value for the DIMZIN system variable.

Examples

VBA:

Sub Example_SuppressTrailingZeros()
   ' This example creates an aligned dimension in model space and
   ' uses the SuppressTrailingZeros property to toggle the display of trailing zeros
   ' in the dimension display

    Dim dimObj As AcadDimAligned
    Dim point1(0 To 2) As Double, point2(0 To 2) As Double
    Dim location(0 To 2) As Double
    
    ' Define the dimension
    point1(0) = 5: point1(1) = 5: point1(2) = 0
    point2(0) = 7: point2(1) = 5: point2(2) = 0
    location(0) = 5: location(1) = 7: location(2) = 0
    
    ' Create an aligned dimension object in model space
    Set dimObj = ThisDrawing.ModelSpace.AddDimAligned(point1, point2, location)
    ThisDrawing.Application.ZoomAll
    
Toggle:
    Select Case MsgBox("Press OK to toggle the display of trailing zeros in the dimension", vbOKCancel)
        Case vbOK
            ' Toggle the display of trailing zeros for the dimension value
            dimObj.SuppressTrailingZeros = Not (dimObj.SuppressTrailingZeros)
            ThisDrawing.Regen acAllViewports
        
        Case vbCancel
            Exit Sub
    End Select
    
    GoTo Toggle
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_SuppressTrailingZeros()
    ;; This example creates an aligned dimension in model space and
    ;; uses the SuppressTrailingZeros property to toggle the display of trailing zeros
    ;; in the dimension display
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))
    
    ;; Define the dimension
    (setq point1 (vlax-3d-point 5 5 0)
          point2 (vlax-3d-point 7 5 0)
          location (vlax-3d-point 5 7 0))
    
    ;; Create an aligned dimension object in model space
    (setq modelSpace (vla-get-ModelSpace doc))
    (setq dimObj (vla-AddDimAligned modelSpace point1 point2 location))
    (vla-ZoomAll acadObj)

    ;; Toggle the display of trailing zeros for the dimension value
    (vla-put-SuppressTrailingZeros dimObj (if (= (vla-get-SuppressTrailingZeros dimObj) :vlax-true) :vlax-false :vlax-true))
    (vla-Regen doc acAllViewports)
    (alert "Suppression of trailing zeros toggled.")

    ;; Toggle the display of trailing zeros for the dimension value back to previous state
    (vla-put-SuppressTrailingZeros dimObj (if (= (vla-get-SuppressTrailingZeros dimObj) :vlax-true) :vlax-false :vlax-true))
    (vla-Regen doc acAllViewports)
    (alert "Suppression of trailing zeros toggled back.")
)