Specifies if the user-defined hatch is double-hatched.
Supported platforms: Windows only
Read-only: No
Type: Boolean
If the PatternType property is set to acHatchPatternTypePreDefined or acHatchPatternTypeCustomDefined, then the PatternDouble property is not used.
VBA:
Sub Example_PatternDouble() ' This example creates an associative hatch in model space. ' It then returns whether or not the pattern is doubled, and ' then changes that value. Dim hatchObj As AcadHatch Dim patternName As String Dim PatternType As Long Dim bAssociativity As Boolean ' Define the hatch patternName = "ansi31" PatternType = acHatchPatternTypePreDefined bAssociativity = True ' Create the associative Hatch object Set hatchObj = ThisDrawing.ModelSpace.AddHatch(PatternType, patternName, bAssociativity) ' Create the outer loop for the hatch. ' An arc and a line are used to create a closed loop. Dim outerLoop(0 To 1) As AcadEntity Dim center(0 To 2) As Double Dim radius As Double Dim startAngle As Double Dim endAngle As Double center(0) = 5: center(1) = 3: center(2) = 0 radius = 3 startAngle = 0 endAngle = 3.141592 Set outerLoop(0) = ThisDrawing.ModelSpace.AddArc(center, radius, startAngle, endAngle) Set outerLoop(1) = ThisDrawing.ModelSpace.AddLine(outerLoop(0).startPoint, outerLoop(0).endPoint) ' Append the outer loop to the hatch object hatchObj.AppendOuterLoop (outerLoop) ' Append the first circle as one inner loop Dim innerLoop1(0) As AcadEntity center(0) = 5: center(1) = 4.5: center(2) = 0 radius = 1 Set innerLoop1(0) = ThisDrawing.ModelSpace.AddCircle(center, radius) hatchObj.AppendInnerLoop (innerLoop1) ' Append the second circle as the other inner loop Dim innerLoop2(0) As AcadEntity radius = 0.5 Set innerLoop2(0) = ThisDrawing.ModelSpace.AddCircle(center, radius) hatchObj.AppendInnerLoop (innerLoop2) ' Evaluate and display the hatch hatchObj.Evaluate ThisDrawing.Regen True ' Determine if the pattern is doubled Dim patternDouble As Boolean patternDouble = hatchObj.patternDouble MsgBox "Pattern doubling: " & hatchObj.patternDouble, , "PatternDouble Example" ' Change the angle of the hatch pattern hatchObj.patternDouble = Not (hatchObj.patternDouble) hatchObj.Evaluate ThisDrawing.Regen True MsgBox "Pattern doubling: " & hatchObj.patternDouble, , "PatternDouble Example" End Sub
Visual LISP:
(vl-load-com) (defun c:Example_PatternDouble() ;; This example creates an associative hatch in model space. ;; It then returns whether or not the pattern is doubled, and ;; then changes that value. (setq acadObj (vlax-get-acad-object)) (setq doc (vla-get-ActiveDocument acadObj)) ;; Define the hatch (setq patternName "ANSI31" patternType acHatchPatternTypePreDefined bAssociativity :vlax-true) ;; Create the associative Hatch object (setq modelSpace (vla-get-ModelSpace doc)) (setq hatchObj (vla-AddHatch modelSpace patternType patternName bAssociativity acHatchObject)) ;; Create the outer loop for the hatch. ;; An arc and a line are used to create a closed loop. (setq center (vlax-3d-point 5 3 0) radius 3 startAngle 0 endAngle 3.141592) (setq arc (vla-AddArc modelSpace center radius startAngle endAngle)) (setq line (vla-AddLine modelSpace (vla-get-StartPoint arc) (vla-get-EndPoint arc))) (setq outerLoop (vlax-make-safearray vlax-vbObject '(0 . 1))) (vlax-safearray-put-element outerLoop 0 arc) (vlax-safearray-put-element outerLoop 1 line) ;; Append the outer loop to the hatch object (vla-AppendOuterLoop hatchObj outerLoop) ;; Append the first circle as one inner loop (setq center (vlax-3d-point 5 4.5 0) radius 1) (setq circle1 (vla-AddCircle modelSpace center radius)) (setq innerLoop1 (vlax-make-safearray vlax-vbObject '(0 . 0))) (vlax-safearray-put-element innerLoop1 0 circle1) (vla-AppendInnerLoop hatchObj innerLoop1) ;; Append the second circle as the other inner loop (setq radius 0.5) (setq innerLoop2 (vlax-make-safearray vlax-vbObject '(0 . 0))) (setq circle2 (vla-AddCircle modelSpace center radius)) (vlax-safearray-put-element innerLoop2 0 circle2) (vla-AppendInnerLoop hatchObj innerLoop2) ;; Evaluate and display the hatch (vla-Evaluate hatchObj) (vla-Regen doc :vlax-true) ;; Determine if the pattern is doubled (setq patternDouble (vla-get-PatternDouble hatchObj)) (alert (strcat "Pattern doubling: " (if (= patternDouble :vlax-true) "True" "False"))) ;; Change the angle of the hatch pattern (vla-put-PatternDouble hatchObj (if (= patternDouble :vlax-true) :vlax-false :vlax-true)) (vla-Evaluate hatchObj) (vla-Regen doc :vlax-true) (alert (strcat "Pattern doubling: " (if (= (vla-get-PatternDouble hatchObj) :vlax-true) "True" "False"))) )