Hatch Object (ActiveX)

An area fill consisting of a pattern of lines.

Supported Platforms: Windows only

Class Information

Class Name

AcadHatch

Object Inheritance
Object
   AcadObject
      AcadEntity
         AcadHatch
Create Using

VBA

ModelSpace.AddHatch
PaperSpace.AddHatch
Block.AddHatch
Access Via

VBA

ModelSpace.Item
PaperSpace.Item
Block.Item
SelectionSet.Item
Group.Item

Members

These members are part of this object:

Remarks

To create a hatch, first create the Hatch object using the AddHatch method. After the Hatch object has been created, add the outer loop using the AppendOuterLoop method. The outer loop must be closed and must be created before any inner loops can be added. After a valid outer loop has been created, add any inner loops, one at a time, using AppendInnerLoop method.

Note: Once the Hatch object has been created, you must add the outer loop to the Hatch object for it to become a valid AutoCAD object. If you attempt any operation other than calling the AppendOuterLoop method, AutoCAD will enter an unpredictable state.