SelectionSets Property (ActiveX)

Gets the SelectionSets collection for the document.

Supported platforms: Windows only

Signature

VBA:

object.SelectionSets
object

Type: Document

The object this property applies to.

Property Value

Read-only: Yes

Type: SelectionSets

The selection set collection for the drawing.

Remarks

No additional remarks.

Examples

VBA:

Sub Example_SelectionSets()
    ' This example finds the current SelectionSets collection and
    ' adds a new SelectionSet to that collection.
    
    Dim SSetColl As AcadSelectionSets
    Set SSetColl = ThisDrawing.SelectionSets
    
    ' Create a SelectionSet named "TEST" in the current drawing
    Dim ssetObj As AcadSelectionSet
    Set ssetObj = SSetColl.Add("TEST")
    MsgBox "A new SelectionSet called " & ssetObj.name & " has been added to the SelectionSets collection.", vbInformation, "SelectionSets Example"
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_SelectionSets()
    ;; This example finds the current SelectionSets collection and
    ;; adds a new SelectionSet to that collection.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))

    (setq SSetColl (vla-get-SelectionSets doc))

    ;; Create a SelectionSet named "TEST" in the current drawing
    (setq ssetObj (vla-Add SSetColl "TEST"))
    (alert (strcat "A new SelectionSet called " (vla-get-Name ssetObj) " has been added to the SelectionSets collection."))

    (vla-Delete ssetObj)
)