ModelType Property (ActiveX)

Specifies whether a plot configuration applies to model space or to all layouts.

Supported platforms: Windows only

Signature

VBA:

object.ModelType
object

Type: Layout, PlotConfiguration

The objects this property applies to.

Property Value

Read-only: Yes

Type: Boolean

Remarks

No additional remarks.

Examples

VBA:

Sub Example_ModelType()
    ' This example creates a plot configuration object
    ' and then finds the ModelType for the object.
    
    Dim PlotConfigObj As AcadPlotConfiguration

    ' Creates the MText Object
    Set PlotConfigObj = ThisDrawing.PlotConfigurations.Add("NewPlotConfiguration")
    
    ' Find the current ModelType
    Dim currModelType As Boolean
    currModelType = PlotConfigObj.ModelType
    MsgBox "The ModelType for the object is: " & currModelType
    
End Sub

Visual LISP:

(vl-load-com)
(defun c:Example_ModelType()
    ;; This example creates a plot configuration object
    ;; and then finds the ModelType for the object.
    (setq acadObj (vlax-get-acad-object))
    (setq doc (vla-get-ActiveDocument acadObj))    

    ;; Creates the MText Object
    (setq PlotConfigObj (vla-Add (vla-get-PlotConfigurations doc) "NewPlotConfiguration"))
    
    ;; Find the current ModelType
    (setq currModelType (vla-get-ModelType PlotConfigObj))
    (alert (strcat "The ModelType for the object is: " (if (= currModelType :vlax-true) "True" "False")))
)