Layout Object (ActiveX)

The plot settings and visual properties of a model space or paper space block.

Supported Platforms: Windows only

Class Information

Class Name

AcadLayout

Object Inheritance
Object
   AcadObject
      AcadPlotConfiguration
         AcadLayout
Create Using

VBA

Layouts.Add
Access Via

VBA

Layouts.Item
Document.ActiveLayout
ModelSpace.Layout
PaperSpace.Layout
Block.Layout

Members

These members are part of this object:

Remarks

The representation of a layout is slightly different in ActiveX from that of the AutoCAD user interface. In ActiveX, the content of a standard AutoCAD layout is broken out into two separate objects: Layout object and Block object. The Layout object contains the plot settings and the visual properties of the layout as it appears in the AutoCAD user interface. The Block object contains the geometry for the layout.

Each Layout object is associated with one Block object. To access the Block object associated with a given layout, use the Block property. Conversely, each Block object is associated with one Layout object. To access the Layout object associated with a given Block, use the Layout property for that block.

In ActiveX, in addition to the paper space layouts, model space is considered a layout.

To create a new layout, use the Add method.